Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Latest Guild Wars 2 Breaks Shaders

[SOLVED] Latest Guild Wars 2 Breaks Shaders 1 year 10 months ago #1

Hi everyone,

I just decided today to check out Guild Wars 2 again after having been away from the game for about a year and a half or so. I discovered that my ReShade was no longer working with it.

I tried multiple different versions, including the following:
  1. ReShade 3.0.6
  2. ReShade 3.0.5
  3. ReShade 1.1.0
  4. ReShade 1.0.0
  5. SweetFX 1.5.1

I tried them all in the main game *.exe directory, in the \bin directory, and in the \bin64 directory. I also tried both DX9 and DX10 versions of the *.dll files (filenames), as well as both 32-bit and 64-bit versions of each of them (2 different *.dll files tried, 4 different filenames tried).

I can't think of anything else to try to make this work. It is possible that ArenaNet simply doesn't want people to use custom shaders of any sort and has managed to detect and disable them, but I'm not sure. The *.log files (when they are actually created, which seems to only work with ReShade 3.0.6 using 64-bit version of the d3d9.dll file) doesn't show any errors or warnings, and it appears that everything should be working, but no shaders seem to have any effect and the settings screen doesn't come up (using SHIFT + F2).

Also, I noticed that the latest version of Guild Wars 2 uses a "d3dcompiler_43.dll" file with a 2.00MB file size and a tooltip File Description of "Direct3D HLSL Compiler", so I was wondering if we need to overwrite that file with the dll file from ReShade, but I tried that as well, and still no success.

I'd appreciate it if anyone could help me get this to work.

Thanks,
Drake
Last Edit: 1 year 9 months ago by DrakePhoenix.
The administrator has disabled public write access.

Latest Guild Wars 2 Breaks Shaders :(... Help? 1 year 10 months ago #2

GW2 definitely works with reshade, since i have it running fine. you're not installing it properly.
The administrator has disabled public write access.

Latest Guild Wars 2 Breaks Shaders :(... Help? 1 year 10 months ago #3

moriz1 wrote:
GW2 definitely works with reshade, since i have it running fine. you're not installing it properly.

Of course! Why didn't I think of that? The fact that I've been able to successfully use and even edit/modify shader systems, such as SweetFX and ReShade v1 in the past with multiple games (including older versions of GW2) combined with the incredible difficulty of installing and using ReShade v3, it must all just be way too difficult for me! And please note the tone of sarcasm. Nothing pisses me off quite like elitist-sounding forum responses that are so useless and asinine as to be a total waste of bandwidth.

If you honestly believe that I'm installing it incorrectly, then please, enlighten me as to exactly how it should be installed (assuming some method other than what I've already tried -- see below). How did you go about installing it?

With ReShade v3 I'm installing by using the downloaded setup *.exe file (for whichever version I'm trying to install), pointing it to the Gw2.exe (for the 32-bit attempts) or the Gw2-64.exe (for the 64-bit attempts), telling it to use DirectX9 or DirectX10 (depending on which version I'm attempting), and then allowing it to download and install the default shaders. Then, when that basic installation doesn't work, I move the newly installed files to the \bin directory and try that, then when that fails I move them to the \bin64 directory and try again, and then when that fails I make duplicate copies of them in the main directory for the game EXEs as well as both the \bin and \bin64 directories. And in all cases I tell the *.ini to check for the shaders in all three directories.

And don't forget what I said in my original post... the LOG file indicates that it should be working and gives no warnings or errors, but the system itself has no effect and I cannot bring up the settings interface.

With ReShade 1 and with SweetFX I am installing directly to the \bin directory (which is exactly how they used to work, and how I have used them numerous times in the past), but since the \bin64 directory is new I have also tried copying the files to that directory, using them in the main directory for the EXEs, and duplicate copies in all three directories, just as with ReShade 3. None of this works.

Does anyone have any *useful* insights?

Thanks,
Drake
The administrator has disabled public write access.

Latest Guild Wars 2 Breaks Shaders :(... Help? 1 year 10 months ago #4

I'm using d3d9.dll / d3d9.ini in the .\bin64 folder (From ReShade64.dll) for the game and that's still working but this game has come up a couple of times so something about it is being problematic. :)

Far as gw2-64.exe goes in the main folder I'm launching that via a shortcut that has the "-autologin" parameter but it doesn't have the full command for skipping the launcher entirely and going straight to the games main menu so it does have to launch gw2-64.exe (Checking for updates and such.) before launching coherentui_host.exe
The administrator has disabled public write access.
The following user(s) said Thank You: DrakePhoenix

Latest Guild Wars 2 Breaks Shaders :(... Help? 1 year 9 months ago #5

Thank you, JBeckman, for confirming that ReShade does still work with GW2, and for stating your installation configuration for it.

I had tried that installation setup, and it didn't work. I double-checked all of the files in all directories within the GW2 installation directory and found that I had missed an old file. It was interfering with the normal installation. I cleaned that up and tried again. I can confirm that it works on my system as well, if there aren't extraneous files.

Thanks,
Drake

P.S. Sorry for the delayed response, I've been very busy with work and family and haven't had time to deal with any of this for a while.
Last Edit: 1 year 9 months ago by DrakePhoenix.
The administrator has disabled public write access.