Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade 3.0 compatibility issues with Minecraft

ReShade 3.0 compatibility issues with Minecraft 1 year 8 months ago #1

tl;dr:
Here's an album on imgur illustrating (and commenting) the problems: imgur.com/a/stGVd
Here's the log file: pastebin.com/cdj786TL
Workaround: toggle fullscreen, but 3.0.5 and 3.0.6 make inventory icons invisible, glitch not present in 3.0.0.

I've setup Minecraft in a way I have a specific Java Runtime setup for the game, with ReShade installed in it, version jre1.8.0_51. Trying to load ReShade on it...works, but the UI is completely broken.

Shaders can load and work well when added manually to the preset file, however it is required to restart the game every time there needs to be a reload (a reload key would be extremely useful here, as the reload button is broken/nowhere to be found).

The UI itself just shows as two white rectangle outlines, the size of the normal ReShade config window and can be moved by dragging an area above the top rectangle, so I'm assuming not everything is broken.

While 3.0.0 can still work just fine with the UI exception, 3.0.5 and 3.0.6 will make inventory icons completely invisible, though it doesn't seem to affect anything else it renders the game unplayable.

Also maybe worth noting, while ReShade is able to stop input processing, it won't be able to display the cursor nor receive mouse input on it's UI when in-game, it only "works" in the main menu, it even doesn't seem to work on the pause menu.

Tested with vanilla 1.11.2 and a modded 1.7.10, though I did not test on other jre versions, 51 is one that prevents a crash on Windows 10 under certain specs so I use it anyway.

UPDATE:
Toggling fullscreen makes the UI work again flawlessly (even the input shenanigans are gone), however 3.0.5 and 3.0.6 still cause the inventory icons to be invisible, check the imgur album for details.

UPDATE 2:
When Graphics is set to "Fast" ReShade, even 3.0.0, seems to cause issues where block faces directly behind transparent blocks are not rendered, showcased in the album. Obvious workaround is to simply set Graphics to "fancy".
Likes to reinvent the wheel.

My shaders repository: www.github.com/luluco250/FXShaders
Last Edit: 1 year 8 months ago by luluco250.
The administrator has disabled public write access.