Welcome, Guest.
Username: Password: Remember me

TOPIC: Styx Master of Shadows, depth buffer

Styx Master of Shadows, depth buffer 1 year 7 months ago #1

Has anyone had any luck accessing the depth buffer in Styx Master of Shadows?
The administrator has disabled public write access.

Styx Master of Shadows, depth buffer 1 year 7 months ago #2

UE4 game, think you just set logarithmic and reversed in the config file and that should do it but there are other factors and some games don't work well with ReShade's way to do depth buffer hooks from what I've read.

In the config file for ReShade it's this string.
RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0,RESHADE_DEPTH_INPUT_IS_REVERSED=0,RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0

To this.
RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0,RESHADE_DEPTH_INPUT_IS_REVERSED=1,RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=1
The administrator has disabled public write access.
The following user(s) said Thank You: Sinclair

Styx Master of Shadows, depth buffer 1 year 7 months ago #3

Thanks, JBeckman -- I tried those, but still no go. It must be as you said that something else about the way the engine was implemented in that game is interfering with the depth buffer hooks.
The game already looks nice to start with, and with some SMAA and MagicBloom it looks even better. But you know how it is with us Reshaders -- we're always looking for more
The administrator has disabled public write access.

Styx Master of Shadows, depth buffer 1 year 7 months ago #4

I tried for a long time to find a depth buffer in that game. I found none. I tried at least 12 different hbao flags with Nvidia inspector too. I think there is no way.

It is really weird as unreal engine is usually working. Anyway I really liked that game.
The administrator has disabled public write access.