Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade not working with latest StarCraft 2 update

ReShade not working with latest StarCraft 2 update 8 months 2 weeks ago #1


Recently StarCraft 2 was updated to version 3.15, and my ReShade doesn't work anymore, even though it used to (just a few versions back). I haven't played SC2 in maybe 2 months, it was fairly recent but in the meantime it seems like Blizzard came up with something that makes the SC2 application crash whenever I install ReShade.

So, what happens is that SC2 itself crashes after launching it normally from the Battle.net launcher. That's also how I used to launch the game back when I played it with ReShade working before that latest update. So the launching method is identical. Additionally, I made sure that ReShade was properly installed, it was. The ReShade installation I was using was untouched from those two months ago or so when I played the game just fine with ReShade working. I did nothing to the files or the .INI settings at all. So that recent 3.15 update did "something" to (directly, or indirectly) ReShade. But instead of just not loading ReShade (like it does in other games when ReShade doesn't work) the application itself crashes (I mean StarCraft 2 crashes, but I'm repeating myself now).

The only "new" thing I tried to make it work this time was to try a new installation in the latest Versions folder, instead of installing it in the Support64 folder (where it was installed originally, and where it worked from back about two months ago). But doing that didn't work, still makes the SC2 application crash.

On a side note the crash results in a 'crash report' window for Blizzard. I decided to not send the report just in case. I don't want to run the risk of being officially "detected" as using a program that they might finally be acting against. On a side note my ReShade still seems to work fine in Diablo 3 and Heroes of the Storm... for now. But not working in SC2 is new to me so I'm not sure what to do about it.

Any suggestions?

Thank you.
The administrator has disabled public write access.

ReShade not working with latest StarCraft 2 update 8 months 2 weeks ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2961
  • Thank you received: 1709
Does the Battle.Net launcher provide any sort of onscreen overlay (OSD)? If so, disable that as it likely interfers with ReShade.
Cheers, crosire =)
The administrator has disabled public write access.

ReShade not working with latest SC2 & HOTS updates 8 months 1 week ago #3

EDIT: I specify in this post's title that now HOTS is also having issues with ReShade (Heroes of the Storm).


Thank you for your reply.

To answer you (and I checked to be sure) there's actually no in-game / on-screen overlay with the Battle.net App after launching a game. If what you are referring to is something like the Steam's or the Origin's overlay (for example, with Steam, if you press Shift + Tab in-game the Steam overlay will pop-up) then indeed the answer is no for Battle.net. At least as far as I know. I checked the Battle.net's own settings (the launcher's settings) and there's no mention of an overlay anywhere, nor have I ever been aware of the existence of an overlay for Blizzard games launched from the Battle.net App.

As of now, however, there's new issues with Heroes of the Storm since today's update, which I had not encountered before. Indeed, today Heroes of the Storm received a new update (Patch 26.3, July 11th), and now ReShade's settings get reset as it tries to load the previously-working settings from just one day ago. In fact it is now the first time that Heroes of the Storm has issues with ReShade. The game launches, then ReShade loads normally, but as it tries to load the chosen shaders and settings the screen flashes bright about two times very quickly, and no actual ReShade settings are applied. Then once I open the ReShade window (Shift + F2) I can see that ALL the settings I have manually adjusted before are all reset to their default values (the shader value settings).

It "started" with StarCraft 2, and now it's Heroes of the Storm's turn. I'm starting to believe that Blizzard is (silently, and internally) taking measures to fight against ReShade. I don't know if that's even possible but supposedly their anti-cheat software does detect ReShade in Overwatch. So maybe they're experimenting with StarCraft 2 and HOTS lately and it actually works. But I'm not sure of course... I'm only speculating. The one thing I know is that it doesn't work in StarCraft 2 at all, and now using it for HOTS results in a "forced" reset of all the shader settings. On a side note, it DOES still work for Heroes of the Storm, but the issue is that it doesn't SAVE the settings anymore because every time I launch HOTS the settings reset. Which means that I have to manually re-do everything if I want to use it with HOTS, which is more of a headache than anything else.

I hope that the issues with both SC2 and now HOTS can be fixed eventually.
Last Edit: 8 months 1 week ago by Mologz.
The administrator has disabled public write access.

Heroes of the Storm (Situation Update) 8 months 1 week ago #4

I just wanted to post an update on the situation for Heroes of the Storm specifically.

I tried a couple of things to make it work properly and, for now, it seems that everything is back to normal (at least for now).

So, within the Heroes of the Storm's installation folder, there's a folder called Versions. And it is within that Versions folder that the latest version of the game's executables can be found (both the regular 32-bit one, and the 64-bit one). Since I had Heroes of the Storm installed for a long time, I ended up having multiple folders of past versions of the game. They're named Base, and then followed by the version number. As of this typing, the current folder (for the latest version) is named Base55288. Which means that every time the game has a significant update, it would create a new folder with a new number and then it would automatically place the game's executables within that latest and newly-created folder.

However, since the ReShade installation dates back to multiple versions ago it meant that the DXGI INI configuration file didn't have the proper pathing in them that pointed to the right folder for ReShade to be properly applied after the game would launch. So to "fix" my issues with Heroes of the Storm I simply deleted all the old version folders to start with to avoid confusion, and then only kept the latest one. Then I looked inside the INI configuration file and manually adjusted the pathing under the "General" section.

After doing that it started to work normally again.
Last Edit: 8 months 1 week ago by Mologz.
The administrator has disabled public write access.