Welcome, Guest.
Username: Password: Remember me

TOPIC: D3D9 not launching after Windows 10 upgrade

D3D9 not launching after Windows 10 upgrade 11 months 2 days ago #1

Hi there strange problem that I haven't been able to track down a fix for; GTA IV and UT2004 (64bit with D3D9) instantly CTD on launch after installing ReShade.
Had no issue running them with ReShade on my Windows 7 install.
I've gone through the common issues thread, tried uninstalling MSI Afterburner and RTSS, uninstalled f.Lux, tried multiple compatibility modes, disabled "fullscreen optimizations" (I hear this is a new thing with creators update), disabled secure boot, ran installer as administrator, ran both games as administrator, installed DX10 SDK, ran the DirectX web updater, etc etc. :S
At my wits end here and most of the threads about crashes with Windows 10 on google are D3D10 or higher so the fixes don't apply. :(

Edit: incase anyone asks it was a fully fresh install of Windows 10 since the NVME drive I'm using was causing BSODs every other boot with Windows 7.
The issue has to be some sort of change with how 10 handles injectors/proxy libraries, be it more restrictive permissions or some other junk.

Edit 2: Got it to work with GTA IV by renaming the d3d9.dll and d3d9.ini installed by the ReShade installer to ReShade.dll and ReShade.ini and using ENB Injector pointed to that .dll file to force it to load. Same method does not work with UT2004-win64.exe though - maybe ENBInjector doesn't work with 64bit executables?

Edit 3: Googling around it seems I'm right about ENBInjector not working with 64bit applications. Someone should make an injector for ReShade64!
Last Edit: 11 months 2 days ago by Lagahan.
The administrator has disabled public write access.