Welcome, Guest.
Username: Password: Remember me

TOPIC: GTA IV + 3.0.8 - depth-related bug

GTA IV + 3.0.8 - depth-related bug 5 months 3 weeks ago #1

so, i'm trying out reshade 3.0.8. installed using the installer, in shader selection stage i've clicked uncheck all, selected fxaa only.
works.

remove reshade, repeat. this time select smaa instead of fxaa.
fail.

screenshot: wstaw.org/m/2017/08/30/GTAIV_30.08.2017_22_10_44.png
fxaa log: wklej.org/hash/c86ec0f4cf0/txt/
smaa log: wklej.org/hash/e55e1f29036/txt/

EnableAutoDepthStencil is disabled and that seems to be the culprit - everything bugs out when effects using depth buffer are loaded - don't even have to be enabled. checked it with MXAA - same result.

AMD A8-7600, integrated graphics, GTA IV version 0.1.0.4.

any ideas?

update: loading few other effects together with fxaa, none of which is using depth buffer afaik, leads to the same bug. so far i've managed to get fxaa working with filmicpass. not a lot of time for testing.

further testing.

first of all, i forgot to add that i've checked GTA IV with all reshade versions from 3.0.1 to 3.0.8, the result was always the same with smaa on the list - i didn't check if fxaa alone would work, but i expect there would be no difference.

second, i'm not sure why in dx10/dx11 modes presentation parameters aren't being dumped in the log. i've checked 2 games with 4 effects on the list (fxaa, smaa, mxao, displaydepth) - rebel galaxy in dx11 mode and bioshock 1 in dx9 and dx10 modes. presentation parameters were dumped only in case of bioshock running in dx9 mode.

and in all those 3 cases, there were no visual bugs. i know that depth buffer isn't supported in bioshock, probably the same story with rebel galaxy, but at least reshade didn't bug out. even more, in case of bioshock in dx9 mode it clearly attempted to initialize the depth buffer - or so i think - EnableAutoDepthStencil is reported to be true.

in all those cases though, i didn't see the depth buffer on the list of textures. no empty buffer, no 0x0 texture, nothing. perhaps it's done differently than in reshade 2, not sure. still, with bioshock running in dx9 mode, outside of the presentation parameters there was no mention of depth buffer whatsoever. that may be by design though.

so far, i would say the issue is GTA IV - related. unfortunately i don't have anything else installed that has perfect compatibility rating, other than DOA5 - which is online, so depth buffer wouldn't work anyway.
Last Edit: 5 months 2 weeks ago by unic0rn.
The administrator has disabled public write access.

GTA IV + 3.0.8 - depth-related bug 5 months 2 weeks ago #2

funny, i've tried to post the update as a separate post and it was considered spam, yet when i've edited the first one - everything went fine.
The administrator has disabled public write access.

GTA IV + 3.0.8 - depth-related bug 5 months 2 weeks ago #3

another test, resident evil revelations. it's supposed to work perfectly - not happening.

log reports EnableAutoDepthStencil set to false, depth buffer is missing. i've checked it with smaa, mxao, displaydepth and two bloom effects loaded - displaydepth didn't even show on the list of effects. at least there were no visual bugs overall, but something seems wrong with depth buffer initialization and i've got a feeling it's the reason behind corrupted visuals in GTA IV. wether it's limited to my config (A8-7600, IGP, win10) or not, no idea, but i would expect other radeon users on win10 to have the same problems.

regarding resident evil revelations, it was constantly switching between controller and mouse+keyboard when using the gamepad - annoyance, because of the message showing up constantly - but that's an unrelated bug i guess. without reshade, nothing like that happens, obviously.
The administrator has disabled public write access.

GTA IV + 3.0.8 - depth-related bug 5 months 2 weeks ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2910
  • Thank you received: 1683
"EnableAutoDepthStencil" has nothing to do with ReShade' depth buffer management and is merely a D3D9 setting that affects whether the driver automatically creates a buffer or whether that's the job of the game engine.
It's very strange to see that using certain effects affects the game rendering though. This should never happen regardless of what effects are used. It sounds like some state is not properly restored after ReShade finished rendering. Considering that ReShade worked fine in GTA4 not long ago, this is interesting however. It would be great if somebody else with different hardware and access to GTA4 could check if the same thing occurs.
Cheers, crosire =)
The administrator has disabled public write access.

GTA IV + 3.0.8 - depth-related bug 5 months 2 weeks ago #5

well, resident evil revelations is another problem - it's supposed to work perfectly, and there's no depth buffer there. if it's unrelated or may somehow help in tracking down the issue with GTA IV - no idea, but worth checking out anyway. after all, it's supposed to work.

is there a way to enable more detailed debug log? some official debug build perhaps? i recall there was such option long time ago, but it's the first time i'm playing with reshade 3.x.
The administrator has disabled public write access.

GTA IV + 3.0.8 - depth-related bug 5 months 1 week ago #6

yet another game, binary domain.

compatibility rating: perfect.
depth buffer: none.

checked using both 3.0.8 and 2.0.3f1. something is very wrong with reshade - and i find it hard to believe it's an issue with win10 creators update, since then we should get tons of depth-related reports.

can we please get an official debug build, writing a detailed log? for me - and i guess many others, which don't care about changing the whole artistic expression of a game by tweaking colors into oblivion - mxao and depth-based smaa are the main interest, and in such case reshade is next to useless.
The administrator has disabled public write access.