Welcome, Guest.
Username: Password: Remember me

TOPIC: How Would I Get Warframe To Work With Reshade?

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #1

So, i've beenh aving problems with the injector, as both 32-bit and 64-bit exectuables (when analyzed) cannot pick up what DirectX or whatever they use.

Is there a manual install of reshade i can do to combat this?
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
Yes, see the readme =). The game is Direct3D11 as far as I know, so you would rename the appropiate ReShade DLL to "dxgi.dll" and copy it into the game folder (where the exe of the actual game is, not the launcher) along with the shaders you want to use.
Cheers, crosire =)
Last Edit: 1 year 10 months ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: Spikyball

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #3

Thanks a lot, really needed the help. Imma try it out ow and will report back
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #4

Yeah, didn't work. No log from the dll, but shader and dll in game root. Help please
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #5

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
And you renamed the DLL? Did you choose the right one (ReShade32.dll for 32bit games, ReShade64.dll for 64bit games, don't know which one Warframe is. And no, it doesn't matter if your Windows is 32 or 64bit, we are talking about the game here) Is it where the game executable is? Mind doing a screenshot? =)
Cheers, crosire =)
Last Edit: 1 year 10 months ago by crosire.
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #6

Yeah, i chose 64-bit for Warframe 64-bit. Running Win 8.1

Do i need to link for a screnshot?
Or can i use it as an attachment

Not sure
Last Edit: 1 year 10 months ago by Spikyball.
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #7

  • jmp909
  • jmp909's Avatar
  • Offline
  • Posts: 135
  • Thank you received: 48
I'm using Windows 8.1 64bit DirectX 11....

* Download Reshade 0.16.0 and MasterEffect 1.11.11 ,
* Copy ReShade64.dll to C:\Program Files (x86)\Steam\\SteamLibrary\steamapps\common\Warframe
* rename ReShade64.dll to dxgi.dll
* copy MasterEffect folder, ReShade.fx and MasterEffect.h from MasterEffect to the same folder
* open the Warframe launcher
* click settings top right
* I unticked DirectX 10 here, so just using DirectX 11

should work then (you'll see the ReShade intro message)

just added a bit of bloom & extra anamorphic here and a couple of lighting tweaks, but the game has already got a lot of them


oh and just so you can see it's definitely working ;)
Last Edit: 1 year 10 months ago by jmp909.
The administrator has disabled public write access.
The following user(s) said Thank You: crosire

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #8

Thank you very much, I will test tomorrow. Thanks!
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #9

  • jmp909
  • jmp909's Avatar
  • Offline
  • Posts: 135
  • Thank you received: 48
Note , depth of field does not work... (Presumably AO as well).... No depth buffer
The administrator has disabled public write access.

How Would I Get Warframe To Work With Reshade? 1 year 10 months ago #10

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
jmp909 wrote:
Note , depth of field does not work... (Presumably AO as well).... No depth buffer
Which is intentional because this is a multiplayer game. =)
Cheers, crosire =)
The administrator has disabled public write access.