Welcome, Guest.
Username: Password: Remember me

TOPIC: Assassins Creed Origins and Reshade problem

Assassins Creed Origins and Reshade problem 10 months 3 weeks ago #1

Hello,

Im a bit stuck on getting reshade 3.0.8 working with Assassins Creed Origins. I tried older versions but most crash when i enter "abilities" menu in-game.

Ive tried different solutions on the net, like changing dxgi.dll to d3d11.dll but both their logs show this message:

-
"Registering hooks for 'C:\Windows\system32\dxgi.dll'
> Delayed until first call to an exported function."
-

Which i believe is the factor as ive not seen that in other games reshade logs except for ME:shadow of war.

I also turned off all overlays including Uplays own but nothing works so far. I dont have any background application running either and ive excluded the game in both firewall and AV application. I literally tried everything within my knowledge.

Writing here is my last resort. Really hope anyone could explain to me what that message means.

Thanks in advance.
The administrator has disabled public write access.

Assassins Creed Origins and Reshade problem 10 months 3 weeks ago #2

Strange, had no problems at all running it with 3.0.8. Didn't have to rename anything. Only issue is a flickering depth buffer as if it's an MMO or something. Running Uplay in offline mode doesn't work either. Other than that, depth buffer is reversed, btw.
The administrator has disabled public write access.

Assassins Creed Origins and Reshade problem 10 months 3 weeks ago #3

The game probably pulls some network traffic doing things like fetching other players data (The vengeance missions.) and the photo sharing on the map. (Which I wish could be turned off rather than just temporarily hidden.) among other stuff (Marketplace data for one.) but ReShade 3.0.8 has worked without problem in this game though the depth buffer needs to be set as logarithmic and reversed to show up. :)

ReShade64.dll as DXGI.dll in my case, Steam version of the game with Steam and UPlay's overlays disabled and then Afterburner/Rivatuner 4.4.0/7.0.0 beta for FPS overlay info and screenshot functionality.

Wonder what that error could be, game uses DirectX 11.x so in that regard it should be compatible as well.
The administrator has disabled public write access.

Assassins Creed Origins and Reshade problem 10 months 1 week ago #4

Am also having a very weird problem wih ACO running any Reshade 3 version:

In order to run ACO with Reshade 3 successfully , I have to reboot my PC (Windows 7 Ultimate 64bit). But if I exit the game and try to run it again, the game does start but hangs forever @ the splash-screen and won't load, though it doesn't crash or gives any error.
I tried deleting my video-settings/cache-files of Uplay/emptied temp&prefetch items/Uplay offline-mode....nothing worked. Not even logging out, I really have to reboot or shutdown my system in order to run it with Reshade 3. But the game does work with Reshade 1 & 2 without any issues.

Here is the dxgi.txt while the game runs successfully with Reshade 3 (after rebooting Windows 7):
Warning: Spoiler! [ Click to expand ]


And here is the dxgi.txt while the game hangs after exiting and restart it (without rebooting Windows 7)
Warning: Spoiler! [ Click to expand ]


Hope this might help with finding a solution.
Last Edit: 10 months 1 week ago by Echo.
The administrator has disabled public write access.

Assassins Creed Origins and Reshade problem 10 months 2 days ago #5

Had the exact same issue, spend an hour trying every possible setting under the moon, disabling RTSS, Afterburner, Radeon Settings, Uplay, ESET, MWB and several other programs but I couldn't get AC:O to launch more than once with Reshade and only whenever rebooting Win7 64. Eventually I got everything working by toggling "Custom Direct3D" support in RivaTuner SS. Hopefully this saves someone else an hour of their life ;)

It's actually worth adding that it didn't work when I disabled RTSS, but turning that specific setting on within RTSS fixed the issue. It's a little bit odd if you ask me but there are so many programs that add an overlay to the game, even Radeon Crimson does for Christ's sake and that's my driver software. I presume RTSS Direct3D support makes it easier for overlays to work together or something and we all know Reshade doesn't play nice with overlays in general, AFAIK Fraps still doesn't work at all for example unless it was fixed since I last used that program.
Last Edit: 10 months 2 days ago by Eolath.
The administrator has disabled public write access.
The following user(s) said Thank You: Echo

Assassins Creed Origins and Reshade problem 10 months 2 days ago #6

Warning: Spoiler! [ Click to expand ]

Awesome weird a$$ find! Thank you Eolath for the solution and your efforts!!
Last Edit: 10 months 2 days ago by Echo.
The administrator has disabled public write access.

Assassins Creed Origins and Reshade problem 2 months 1 week ago #7

I still have this problem unfortunately. Can't seem to get Rivatuner SS to run either. Is there another solution to this? I WAS running the game fine for awhile but now it no longer seems to get past the launch screen. I get the same log with the delayed and exporting function issue. Running Windows 7 64 bit.
The administrator has disabled public write access.