Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Guild Wars 2 and ver 0.16 not hooking

Guild Wars 2 and ver 0.16 not hooking 2 years 2 months ago #1

  • cc
  • cc's Avatar
  • Offline
  • Posts: 4
Hello, I am having some difficulty getting ReShade (0.16) to work with Guild Wars 2. I have googled around and found various instructions, such as this thread:

reshade.me/forum/troubleshooting/239-solved-reshade-with-gw2

and a few others but they don't seem to solve my problem. As instructed, I renamed ReShade32.dll to D3D9.dll and placed it alongside Sweet.fx and the SweetFx folder from the "ReShade 0.16.0 Public Beta with SweetFX 2.0 Beta 8" archive into the Guild Wars 2\bin\ folder. I added the -autologin -nopatchui -email MYEMAIL -password MYPASSWORD command line arguments to my GW2 shortcut (as the launcher will crash trying to load the patcher/login menu otherwise). However once the client loads I see no shader effects or any indication at all that ReShade has loaded. I have tried placing the files in the root Guild Wars 2\ folder instead of bin just to be sure, but this prevents the client from loading (MSVCPP110.dll is missing error, despite the relevant package being properly installed. Some kind of failed directory contents integrity check?)

The ReShade Setup program crashes when I try to run it using Gw2.exe with the following details:
Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	reshade setup.exe
  Problem Signature 02:	1.5.2.0
  Problem Signature 03:	5456765a
  Problem Signature 04:	ReShade Setup
  Problem Signature 05:	1.5.2.0
  Problem Signature 06:	5456765a
  Problem Signature 07:	79
  Problem Signature 08:	0
  Problem Signature 09:	System.MissingMethodException
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Any hints on getting this working would be appreciated, thank you!
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 2 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2652
  • Thank you received: 1521
Do you have "Razer Cortex: Game Booster" installed? Somebody once had the issue that this app would prevent ReShade from loading at all.
Cheers, crosire =)
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #3

  • cc
  • cc's Avatar
  • Offline
  • Posts: 4
Thanks for the reply.. nope, don't have that installed. No other GPU-related programs running either, unless you count the Aero desktop..
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2652
  • Thank you received: 1521
What happens if you create an empty textfile in that folder and rename it to "d3d9.dll" (including the extension!)? Or "dxgi.dll"?
Cheers, crosire =)
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #5

  • cc
  • cc's Avatar
  • Offline
  • Posts: 4
Oops, looks like my last quick reply got eaten..?

Anyway experimenting with the empty textfiles and both dlls, I think I narrowed it down to: ReShade64.dll seems to be the correct file to use, and it needs to be renamed as d3d9.dll in the root GW2 folder. DLLs (empty or otherwise) in the bin folder are ignored and the 32-bit dll in the root folder returns an error of MSVCP110.dll not being found (despite being installed properly)

However with the 64-bit DLL the application launches, but still doesn't hook in. When I examine the loaded DLLs for the gw2.exe process with Process Explorer, it lists d3d9.dll as being located in C:\Windows\SysWOW64\d3d9.dll. So despite needing the correct file to launch the application, it's still ignoring it somehow and just defaulting to the native Windows DLL I think?
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #6

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2652
  • Thank you received: 1521
cc wrote:
32-bit dll in the root folder returns an error of MSVCP110.dll not being found
Then it's this one that is the correct DLL to use =). Game is 32bit and thus doesn't load the 64bit DLL of ReShade (which is why it's not in the list of loaded modules).

I'd suggest you uninstall the Visual C++ 2012 redistributable from your system and then download and install both the x86 and x64 versions again.
Cheers, crosire =)
Last Edit: 2 years 1 month ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: cc

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #7

  • cc
  • cc's Avatar
  • Offline
  • Posts: 4
Ahhh I see.. I gave that a try and that did the trick. Working perfectly now! Thanks!



The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #8

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2652
  • Thank you received: 1521
Glad to hear it =)
Cheers, crosire =)
The administrator has disabled public write access.

Guild Wars 2 and ver 0.16 not hooking 2 years 1 month ago #9

  • Sassy
  • Sassy's Avatar
  • Offline
  • Posts: 33
  • Thank you received: 3
You can put your files back into the \bin folder and remove the -nopatchUI,-password and -email command aswell. An install of reshade into the main folder is only needed when you don't load the patchUI.
The administrator has disabled public write access.