Please help, Watch Dogs crashes on start up

  • Posts: 3
5 years 3 months ago #1 by souljabuster
Hello, i am trying to get reshade working on watch dogs, but whenever i try to launch the game, it crashes
Here is the log for d3d9 and dxgi
Had to put them in onedrive because when i pasted them the post was seen as spam

1drv.ms/1FWplQA

I have the encoding for the SFX settings at ansi and reshade settings is ansi too.

What could it be ? Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 3741
5 years 3 months ago #2 by crosire
First you would want to update ReShade. You're running version 0.14.0, but we are at 0.16.0 already =). Next make sure no interfering software is running (overlays, game boosers, recording software and such).

Please Log in or Create an account to join the conversation.

  • Posts: 3
5 years 3 months ago #3 by souljabuster
Thanks for the quick response,
I did what you said, updated it to .16. Then i made sure that no overlay was interfering.
Still does not work.
1drv.ms/1FWplQA
^ this is what i get now in the logs

Please Log in or Create an account to join the conversation.

  • Posts: 3741
5 years 3 months ago #4 by crosire

souljabuster wrote: Here is the log for d3d9 and dxgi

But you are only using one of the two and not both at the same time I hope? Also, game is D3D11, so no need to check with D3D9.

Please Log in or Create an account to join the conversation.

  • Posts: 3
5 years 3 months ago #5 by souljabuster
I tried to do it with dxgi, d3d9, and then both dxgi and d3d9.
All times it crashes.

If it helps i am on windows 8.1

Would i need to have d3d11 dll?

Please Log in or Create an account to join the conversation.

  • Posts: 88
5 years 3 months ago - 5 years 3 months ago #6 by kgonepostl
in this particular instance rename the reshade64 file to dxgi

Please Log in or Create an account to join the conversation.

  • Posts: 81
5 years 3 months ago - 5 years 2 months ago #7 by Mobeeuz
Same Problem for me, Reshade64.dll = DXGI.dll, version 16, no reshade.fx at all. Tried with Steam and UBI overlays off, no difference.

Please Log in or Create an account to join the conversation.

  • Posts: 14
5 years 2 months ago - 5 years 2 months ago #8 by One3rd
Did this work in v15? I've just tried it out and am having similar problems with it crashing in 0.17.1. It gives me the below log.
Log file

This is the first time I've tried out the new framework build though so not sure if I'm doing something wrong.

Please Log in or Create an account to join the conversation.

  • Posts: 14
5 years 2 months ago - 5 years 2 months ago #9 by One3rd
I've tried this with every version down to 0.13.0 and they all crash at startup. The compatibility list shows that 0.13.0 works perfectly with Watch_Dogs, was there something unique in the way ReShade needed to be installed or setup to facilitate this?

There seem to be a number of these warnings in the logs, what do they mean?
15/04/2015 17:11:44:555 [03808] | WARN  | Reference count for 'IDXGIDevice' object 0000000019A9EA50 is inconsistent: 2 vs 0.
15/04/2015 17:11:44:555 [03808] | WARN  | Reference count for 'ID3D11Device' object 0000000014C86D30 is inconsistent: 1 vs 0.

Please Log in or Create an account to join the conversation.

  • Posts: 28
5 years 2 months ago #10 by TreppenBananenHutstaender
i have the same problem

Please Log in or Create an account to join the conversation.

  • Posts: 28
5 years 2 months ago #11 by TreppenBananenHutstaender
any help?

Please Log in or Create an account to join the conversation.

  • Posts: 14
5 years 2 months ago #12 by One3rd

TreppenBananenHutstaender wrote: any help?

Sorry, I should check this forum a bit more regularly. I was able to get ReShade working with my setup finally. I'd also been troubleshooting random CTD's I was having with the game even without trying to use ReShade and one of the things I did was to clear out all temporary files. I'm still have random crashes but on a whim I tried ReShade 0.18.1 again...and it worked!

I changed two things from it crashing on start up to working.

1. Cleared out all Windows temporary files (10GB worth!). The steps for this UBIsoft Support provided are below.

Delete all temporary files from your system.
Hold the windows key and press the 'R' key, this will open the Run window
Type 'temp' then click OK or Navigate to C:\Windows\Temp and delete all files in this folder.
Type '%temp%' then click OK or Navigate to C:\Documents and Settings\*Your User Name*\Local Settings\Temp and delete all the files in this folder.

You may need to turn on the ability to view hidden files and folders to do this. To do so, double click My Computer, then click Tools and Options. Then click View and select the option to view all hidden files.
Then reboot and try the game again.


2. Completely uninstalled all NVidia drivers and performed a clean re-install.

I'm also running the game with all overlays off, with UPlay in offline mode, and starting up MSI Afterburner (for screenshots) after the game has started.
I'm not sure if this will work for you as well but it's worth a shot.

Please Log in or Create an account to join the conversation.

  • Posts: 28
5 years 1 month ago #13 by TreppenBananenHutstaender
I tried it again with Reshade 0.18.4/0.18.5 and with the things One3rd sayed but it still crashes.

Please Log in or Create an account to join the conversation.