Welcome, Guest.
Username: Password: Remember me

TOPIC: Dawn of War Soulstorm (Steam) crashing on startup

Dawn of War Soulstorm (Steam) crashing on startup 1 month 3 weeks ago #1

  • Meddy
  • Meddy's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 2
Since the last big Windows update, my Steam edition of Soulstorm has been crashing on startup. Been trying to get this to work for a month or two now. I'm currently using ReShade 3.0.4 since the newer releases don't hook properly as detailed in this old thread: reshade.me/forum/troubleshooting/3276-re...awn-of-war-soulstorm

Prior to the Windows update the game was a bit finicky to launch, but after a couple tries it would work. Now, the executable appears in my processes but the renderer never starts up and then crashes after a minute or two. Sometimes the game will launch in windowed mode for a split-second before crashing, but mostly it just throws up the Relic error reporter. Here's my d3d9.log:

Warning: Spoiler! [ Click to expand ]


None of the actual game crashlog files show any errors either.

I've tried various older builds of ReShade and SweetFX but nothing works now. I'm currently running an NVIDIA GTX 1070 Ti if that makes a difference, but until now I've never had this much trouble getting ReShade to work with my current card or even my old R9 290. I've also tried disabling my Steam and NVIDIA in-game overlays to no avail. I even tried rigging the old ENBinjector to inject a different way but it doesn't catch the game executable while it's starting.

Interestingly enough, the GraphicsConfig.exe renderer test has always worked and still works flawlessly with ReShade.

UPDATE: Alright, so I installed my original hard copy of the game for the hell of it, patched it to the latest version and everything works perfectly. Even starts up in fullscreen mode unlike the Steam version when it worked.

Problem is I can't play online with the non-Steam version so it's pointless.

Either way, this is leading me to believe Steam might be blocking or interfering with the injection somehow. Still open to any suggestions
Last Edit: 1 month 2 weeks ago by Meddy. Reason: Combined posts
The administrator has disabled public write access.

Dawn of War Soulstorm (Steam) crashing on startup 1 month 2 weeks ago #2

  • Meddy
  • Meddy's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 2
Okay, so figured out a couple workarounds for anyone that stumbles across this thread.

Boulotaur2024's injector w/ SweetFX 1.5.1 works:
dropcanvas.com/iz7s1

ReShade Public Beta 0.10.0 w/ SweetFX 2.0 also works:
www.mediafire.com/file/mrscmdauqq9ab2t/R...eetFX+2.0+Preview.7z

So those builds work if you're happy only using SweetFX. In order to get the CustomFX, GemFX and McFX shaders like LUT, Adaptive Sharpen, etc. working, I had to combine the injector from the 0.10.0 build above with the framework from an ancient ReShade package I had laying around for MGS V - The Phantom Pain. I packaged together my working build for anyone interested here:
dropcanvas.com/tcqs4

Unfortunately that release is an absolute bear to set up and has errors-a-plenty, but it supports LUTs, so good enough for now I suppose. You might be able to combine the 0.10.0 injector with some newer versions of the framework or maybe even one of the Master Effect builds but I haven't experimented.

Would be amazing to see this properly fixed in one of the newer builds of ReShade if possible, but at least I got something working for now.
Last Edit: 1 month 2 weeks ago by Meddy.
The administrator has disabled public write access.