Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade-OpenGL not working after updating to W10

Reshade-OpenGL not working after updating to W10 5 months 3 days ago #1

Hi all.
I was using Reshade with Windows 7 without any trouble.
Now, I'm not able to make it work since I've updated to Windows 10.
I'm trying to use Reshade with Final Fantasy VII. This is the message I got:
"OpenGL renderer does not support OpenGL 2.0. Your graphics drivers are probably not up to date. Shaders are required since version 0.8."
I have every driver installed and updated. These are my system specs:
ASUS H97M-PLUS
Intel Core i5-4570
16 GB RAM DDR3 1667.
GTX 760 2GB

I have looking for some replies on google, however I didn't get nothing else though.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 3 days ago #2

I second this as windows 10 seems to be the only solution I haven't tried yet.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 3 days ago #3

Windows 10 a solution? It is fact my problem! xD
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 2 days ago #4

You got me. :) what a dad joke.
Last Edit: 5 months 2 days ago by Soscean.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 2 days ago #5

I have read something about ReShade 3.0.4 working with in a similar situation like mine. Anybody knows where can I find the 3.0.4 version for be downloaded?
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 2 days ago #6

I got it working!
Just downloaded and installed the 3.0.8 versiones of ReShade from here: reshade.me/forum/general-discussion/294-...-repository-new-host
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 2 days ago #7

Congrats! Now leave this place behind and enjoy. 3.0.8 does not work for me, however. Oh well.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 1 day ago #8

Feels like something NVidia might have done with the Windows 10 drivers but that's strange.

www.geforce.com/hardware/desktop-gpus/ge...x-760/specifications

Going by that then spec wise the 760 supports OpenGL 4.3 which I believe 4.2 was the required version for ReShade to work and since it worked on Windows 7 that's obviously not the problem.

Does an earlier version of ReShade work? If that repository has the entire range of 3.0.0 to 3.1.1 available then it's mostly a matter of time just trying each .DLL and seeing what happens but if none of them work I would question if it's something the drivers are doing.

I'm on AMD though, I can give some suggestions but I try to avoid OGL, performance is a problem as-is and then you have compatibility issues on top of that and then trying to add ReShade in well it usually doesn't work well.

Does caps viewer report anything for OpenGL support?
www.ozone3d.net/gpu_caps_viewer/

If it shows 4.2.0 as supported (Or higher.) then that eliminates the driver as a source of problem too but then what's left? The OS perhaps I don't see Windows 10 alone affecting OpenGL, much.


EDIT: I guess there's Freestyle in the 390.65 drivers as a variant of ReShade in the display drivers directly but I don't think it supports OpenGL yet and it has a more strict set of shaders which I don't believe you can add to yourself. Still that could be one alternative once they do support OpenGL.
(Though you will also need the newest version of GeForce Experience installed, currently that's 3.12.0.84 I believe.)
Last Edit: 5 months 1 day ago by JBeckman.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 1 day ago #9

Before I continued troubleshooting this program, I certainly tried Freestyle, but kotor is not supported by GeForce experience.

I got this error in the opengl doc. I don't know if that sheds light on anything.
19/01/2018 08:45:38:868 [06960] | WARN | > Single buffered OpenGL contexts are not supported.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 1 day ago #10

Curious, Knights of the Old Republic uses OpenGL 1.4.0 (~2003) and Final Fantasy VII from the opening post uses OpenGL 1.1.0 (~1998) I had assumed ReShade required at least OpenGL 2.0 support in the actual game but then I see in the other thread that ReShade looks to be working in KOTOR 1 for that user (Though it needed to be a older version.) so that invalidates that argument entirely.

I'm a bit stumped. If it's related to threading there's a setting in NVidia's control panel for OpenGL called threaded optimization which has auto (profile based.) on and off so turning that off for these games might help but it might not be what is causing the problem.

And for the games and since they are 32-bit I would have ReShade32.dll loaded as OpenGL32.dll since that's the API these games use but some games work better through D3D9, DXGI or D3D11 .dll although it usually works best with the same API the game is using. :)
(OpenGL32.dll and not OpenGL.dll just to clarify, even for 64-bit software it's also called OpenGL32.dll but I'm guessing the ReShade setup utility takes care of this, I don't it much myself.)

I can't really be of much help unfortunately so a few suggestions is the best I can offer hopefully it helps but my own knowledge about ReShade and OpenGL and then driver specific issues and limitations on top of OS differences is a bit lacking so hopefully other users will be able to give some better answers than what I can offer though these forums aren't always very active.

It's interesting that it apparently also worked fine in Windows 7 and then broke when the system was updated.
And since Freestyle was mentioned you are probably already using the latest available drivers too so nothing like that.
(Whereas Windows 10 and it's automated way of handling drivers periodically has it pulling a old driver and installing that if you're not careful or disable it.)
Last Edit: 5 months 1 day ago by JBeckman.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 5 months 22 hours ago #11

I appreciate the help regardless, friend. Altough ive gone no where with reshade, ive learned quite a bit about all peripheral issues, so its worth it.
The administrator has disabled public write access.

Reshade-OpenGL not working after updating to W10 4 months 4 weeks ago #12

I have to say I got it working with 3.0.8 version, but using Direct10 option (dxgi.dll), not the OpenGL one. I couldn't make it work with any other dll or ReShade version on Windows 10. When I was using Windows 7, then I had the most up to date version of Reshade with the OpenGL option selected.
The administrator has disabled public write access.