Welcome, Guest.
Username: Password: Remember me

TOPIC: Witcher 3: ReShade completely ignores it! Help!

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #1

Hi everyone,

I recently decided to finish Witcher 3 for the second time given that I finally got a much better PC.
Anyways, I've tried every single Reshade version up to the newest one and none of them work. I remember using both SweetFX and later ReShade with it in the past and it worked flawlessly.

I've read that one of the game updates added a dxgi.dll file to the game bin folder and that it simply conflicts with the ReShade one. That made me fiddle with it a bit and none of the combinations that I've tried worked. I've read to move the Witcher 3 dxgi.dll someplace else or completely delete it, keep it in the game folder and rename ReShade's dxgi.dll to d3d9 or d3d11. None of it works :(.

Does anyone have any clue as to why Witcher 3 is incompatible with ReShade nowadays? It really sucks given that SweetFX/ReShade is the only program that allows you to enhance visuals on the fly and is so easy to use. Heck, I can't really think of any other program that allows such graphics enhancements, maybe aside of ENB, but that's what I'd say is a completely different thing.

Thanks in advance for any help :)!
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #2

Really nobody can help? Can the creator of ReShade give any input? I really don't have a clue why isn't it working. First Sleeping Dogs isn't working with ReShade and now this.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #3

ReShade works perfectly fine with Witcher 3. Install to "\The Witcher 3 Wild Hunt\bin\x64\witcher3.exe" so that the setup creates "\The Withcer 3 Wild Hunt\bin\x64\dxgi.dll". Make sure you disable the GOG in-game overlay before installing ReShade.
Cheers, crosire =)
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #4

Did just that and it seems to simply ignore the game/.exe for some reason. I know that one of the patches for the game added its own dxgi.dll file, but I just reinstalled the game and it's not there so I assume CDPRed team removed it. Anyways, I just tried the newest ReShade, used its setup, directed it to the game's .EXE, chosen the Shaders to download and upon launching the game there's no ReShade pop-up like there usually is. Nothing. Almost like it is ignoring the game for whatever reason.

I'm using Game of the Year Edition and Windows 10. Can ReShade have some compatibility issues with Windows 10? When I was playing Witcher back in 2015 for the last time SweetFX/ReShade worked perfectly, but I was under Windows 7 then.

I don't want to sound like an entitled brat as this program is offered for free and I really appreciate and respect all the hard work that you've put into it :). I simply don't understand what the issue here is.

Here's what the vanilla folder looks like:


Here's what it looks like with ReShade:
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #5

Make sure the DLL is the 64-bit version of ReShade (properties > file description).
Cheers, crosire =)
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #6

I just found the culprit then. I didn't even think about it. The dxgi.dll in properties states that its original name is "ReShade32.dll" :ohmy:. Why is ReShade installing the 32-bit and not 64-bit?

I just found an old SweetFX 2.0 ReShade64.dll on my PC. It is loading ReShade now but as ReShade 2.0 :/. Why the most recent ReShade versions on this website only have 32-bit files then? I wasn't able to run it in other 64-bit only games as well and now I know why.
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #7

Run the setup and ctrl click the select button for it to extract both DLLs. Then simply copy over the 64-bit one and rename it.
Cheers, crosire =)
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #8

It finally works now, but since I've placed the said renamed ReShade64.dll in the bin folder, I'm missing all of the shaders I decided to download for it. They're in the bin folder in the "reshade-shaders" folder, but don't show up in ReShade menu in-game. I assume that it's due to some conflict of placing a dxgi.dll separately rather than via the setup.exe itself.

Why is ReShade installing 32-bit by default and can't detect whether the game needs 32 or 64-bit files?

Sorry for so many questions, but I've been using SweetFX since 2012 when Sleeping Dogs came out and never had a similar problem.
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #9

I'm completely lost now. It started working and yet it's useless as it doesn't load the shaders from the shaders folder. The paths in the in-game ReShade menu are all correct as well.
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #10

The path is not correct or else it would load the shaders. It should be "<Path to Witcher>\bin\x64\reshade-shaders\Shaders". The setup does nothing else apart from copying the DLL there and downloading shaders. Everything can be done manually with ease too.
Cheers, crosire =)
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #11

I guess I found the issue then. My game folder contains a Polish letter, which looks like that "ΕΊ". ReShade simply doesn't recognize it. It initially changed it to the letter "z" and when I swapped it with the Polish letter again it simply changed it to a question mark.

I guess I'll have to re-download the game again and leave folder name free from any non-English symbols. Thanks again for all the input. Hopefully it'll finally work :)!
Last Edit: 7 months 1 week ago by budyll.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #12

Just drag the Witcher 3 folder out of the other one and adjust the path in Reshade. Should be fine then. No need to download again, really.
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #13

Yes, you can move the shaders anywhere you want. Also, in theory ReShade does support Unicode paths. Make sure the INI is stored with UTF8 encoding. If that doesn't work something is wrong with ReShade 's INI parser.
Cheers, crosire =)
The administrator has disabled public write access.

Witcher 3: ReShade completely ignores it! Help! 7 months 1 week ago #14

Everything is perfect now guys. I simply removed the Polish symbol/letter from the game folder name in registry and reinstalled ReShade :). Thanks for all the help and for bearing with me, but it was simply driving me crazy as it was refusing to work in newest games for a good few months and I had no clue why. I never even thought that it may simply be installing the wrong bit version of the file xD.
The administrator has disabled public write access.