Welcome, Guest.
Username: Password: Remember me

TOPIC: (TS18) 3.1.2 freeze problem and how it went away

(TS18) 3.1.2 freeze problem and how it went away 3 months 1 week ago #1

Hi guys,

My apologies if I sound like your grandmother on all things IT, but I've been running into trouble with Reshade Train Simulator 2018 and I can't for the life of me figure out what's going on.

Yesterday I installed 3.1.2, intending to use it with Train Simulator 2018 (Railworks). Ran into some trouble (no access to path when extracting files, quite a few people experience this problem), but after a few installs it worked. Great stuff by the way, just what the doctor ordered!

Then suddenly my game started freezing at loading, or right after. I did install some packs in the meantime mind you, and I didn't test if they're the cause yet. But I did try fiddling around with different versions of reshade. Nothing seemed to work. But just now I reinstalled 3.1.2 and I reinstalled several times over, choosing different API's... So I installed DX9, DX10 and OpenGL version. And presto... It worked again.

Long story short:

I now have both d3d9.dll and dxgi.dll in my railworks folder, and that seems to be the only way to get reshade and TS18 running without problems (still looks great!). Removing either of them has my game freezing at load/startscreen.

No idea what to make of it, but I thought I'd share it and maybe someone can help me understand it. I hear a lot of people about freezes at loading, so maybe understanding why this is happening could help people out.
Last Edit: 3 months 1 week ago by TLP.
The administrator has disabled public write access.

3.1.2 freeze problem and how it went away 3 months 1 week ago #2

Aaaaaaaaaandddd... it's gone.

Stopped working again. Absolutely incomprehensible. Back to square one, game freezes at load.

Either Steam, TS2018 or Reshade is undergoing some sort of daily change that messes things up. I restarted the game a few times after I got it working again and there was no problem.

I have no idea what this is or what I can do about it.

Any help would be greatly appreciated, even if it is just putting me on the right track. This is just weird to me and I want to know what's going on. Thanks in advance!

Edit: just reinstalled again, and it only works when I use the installer to install all API versions, and then remove OpenGL.dll. For how long? Time will tell.

Also, changing Nvidia settings to full dynamic range (I have a HDTV monitor) seems to interfere with the proper workings.
Last Edit: 3 months 1 week ago by TLP.
The administrator has disabled public write access.