[SOLVED] Use Reshade on VisualboyAdvance doesnt work

  • Posts: 5
2 years 4 weeks ago #1 by Dixcal
Hey guys !,

For a few days im trying arround to get reshade working on the GBA emulator. After changing the Settings of the Emulator to run the Games with OpenGL reshade finally started ! But its not working at all. Take a look at the picture and you will see whats the problem. I hope you can help me out !

Thanks!

Link to the picture : ibb.co/mkLRXT

Please Log in or Create an account to join the conversation.

  • Posts: 118
2 years 4 weeks ago - 2 years 4 weeks ago #2 by acknowledge
Better to use the VBA-M emulator, it's much more compatible with modern pc.
The following user(s) said Thank You: Dixcal

Please Log in or Create an account to join the conversation.

  • Posts: 5
2 years 4 weeks ago - 2 years 4 weeks ago #3 by Dixcal
Thank you for the suggestion. but reshade doesent even start on this Emulator. Or is there something i do wrong?

EDIT: I managed it to start. But its still the same issue like in the picture above. Non read able Hieroglyphes.

Please Log in or Create an account to join the conversation.

  • Posts: 3747
2 years 4 weeks ago #4 by crosire

Please Log in or Create an account to join the conversation.

  • Posts: 5
2 years 3 weeks ago - 2 years 3 weeks ago #5 by Dixcal
Hmm okay thank you for this link but i have no idea what i can do with this information :oops:


EDIT: A friend of mine helped me out to implement the gifhub datas in the reshade exe.
here is the link for those of you who want to use it on the GBA emulator !


www.file-upload.net/download-13226781/ReShade_Setup.exe.html

EDIT2: Sadly it didnt worked out perfect. Reshade starts now in the correct readable way but the shaders and FX´s are
not inside of the "reshade box" Here a link to a picture :

ibb.co/mu37Go

Please Log in or Create an account to join the conversation.

  • Posts: 228
2 years 3 weeks ago #6 by Uncle Crassius
You may have to set the correct paths to shaders and textures manually under the "Settings" tab.

Please Log in or Create an account to join the conversation.

  • Posts: 5
2 years 3 weeks ago #7 by Dixcal
The paths are allright.

Please Log in or Create an account to join the conversation.

  • Posts: 3747
2 years 3 weeks ago #8 by crosire
That link was just a diff of what has changed. Those changes will be available sometime in the future in an official release. But I won't release a new version for every small modification, so until then, you have to compile ReShade yourself to get those changes. Looks like your friend already helped you there.

There is a check that prevents all shaders from compiling for ReShade versions earlier than 3.0. You did not set the version when you or your friend compiled ReShade, so it thinks it is ReShade 0.0.0.2 and therefore doesn't compile any shaders which require 3.0.0.0+. You can bypass this check by removing the following line in reshade-shaders\Shaders\ReShade.fxh:
#error "ReShade 3.0+ is required to use this header file"

Please Log in or Create an account to join the conversation.

  • Posts: 5
2 years 3 weeks ago - 2 years 3 weeks ago #9 by Dixcal
Thank you so muchit worked ! :)



EDIT : I wanna share the result I uploaded a liitle youtube video. just ignore that Background noices :D

Please Log in or Create an account to join the conversation.

  • Posts: 1
2 years 1 week ago #10 by pablo987
I had faced this same issue. But then someone told me to use VBA-M emulator and really it works. So you can also try this one.

Please Log in or Create an account to join the conversation.