Welcome, Guest.
Username: Password: Remember me

TOPIC: Getting ReShade to Work w/Warframe in July 2018

Getting ReShade to Work w/Warframe in July 2018 4 months 21 hours ago #1

I got ReShade 3.4.0 working great with Warframe and here's how I did it. I hope this saves people time and frustration:

I set the game to borderless windowed mode first and closed it. Then, I downloaded the latest version of ReShade, 3.4.0, ran the .exe, chose Warframe.x64.exe, chose directx 10+, renamed the reshade files from dxgi.dll and dxgi.ini to d3d11.dll and d3d11.ini and, arguably most importantly, opened up the properties for the d3d11.dll and set it to read-only. Else the game will delete the .dll file on launch. Don't set the .ini file to read-only or you won't be able to modify your reshade (or the changes wont save anyway). 

Launcher settings:

fullscreen - unchecked
directx 10 - checked
directx 11 - checked
64-bit mode - check
bulk download - uncheck
aggressive download - uncheck
multithread rendering - check
launcher gpu acceleration - check

And I think i accidentally hit the optimize button at some point and accidentally hit verify files, but both of those were before installing reshade, since I was having trouble getting the game to run at all from the launcher.
_________________________________________________________________________________________________________________________________________________________________
Images to show. I mostly just downloaded this game so I could create reshades for it, as  have a YouTube channel that is pretty much based on me creating/releasing reshade. I don't know why but I can't seem to reply to any message boards yet. I did just download the game today, so perhaps there's a restriction on doing that. 

Here's my youtube channel if you need credibility that I'm not just a troll: www.youtube.com/channel/UCn5KAZuLeVmeQLXSMJNBMcA

Hope this helps!

Proof:

https://scontent-iad3-1.xx.fbcdn.net/v/t1.0-9/37301806_712660272410752_4562299830168190976_o.jpg?_nc_cat=0&oh=8ea9dbb0cd8e1dc59f6a91863e401443&oe=5BCD0DFA
https://scontent-iad3-1.xx.fbcdn.net/v/t1.0-9/37394710_712660742410705_7764854641245814784_o.jpg?_nc_cat=0&oh=a6b9449527de79bb824d8617df8ffc49&oe=5BD535CF
https://scontent-iad3-1.xx.fbcdn.net/v/t1.0-9/37255074_712660975744015_5087801667382935552_o.jpg?_nc_cat=0&oh=7bcfb8617179ad7ceaaa73d91df0513a&oe=5BC63AF7

Edit: Can someone please remind me how to post the bleeping images, not just links to images? Thanks so much!
Last Edit: 3 months 3 weeks ago by AssassinsDecree.
The administrator has disabled public write access.

Getting ReShade to Work w/Warframe in July 2018 4 months 3 hours ago #2

Here's a video showing it works:

Also, can anyone help with making those pics post correctly? #thesmallthingsarethehardest. Thanks!

-Merc
Last Edit: 4 months 3 hours ago by AssassinsDecree.
The administrator has disabled public write access.

Getting ReShade to Work w/Warframe in July 2018 4 months 2 hours ago #3

AssassinsDecree wrote:
Also, can anyone help with making those pics post correctly? #thesmallthingsarethehardest. Thanks!
The forum doesn't understand query strings in the image URL (the stuff behind "?"). Parsing fails and the image isn't displayed. Unfortunately Facebook doesn't accept the URL without those query parameters, so you need another image hoster for it to work.
Cheers, crosire =)
Last Edit: 4 months 2 hours ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

Getting ReShade to Work w/Warframe in July 2018 4 months 1 hour ago #4

THANKS SO MUCH, CROSIRE! I thought I was going insane because I had got images to post successfully a few weeks or month ago but couldn't figured out what I was doing differently. I do believe I used Flickr before.

Have a great day!
The administrator has disabled public write access.

Getting ReShade to Work w/Warframe in July 2018 6 days 9 hours ago #5

Thanks for the instructions, I had to also run the game in Windows 8 compatibility mode for it to work.
Last Edit: 6 days 9 hours ago by Iyney. Reason: updating comment
The administrator has disabled public write access.