Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade causes all opengl games to crash on launch

Reshade causes all opengl games to crash on launch 4 weeks 2 days ago #1

So, some background. I've been looking for a solution to this problem (which appeared at some point after updating my nvidia drivers and trying a more recent version of Reshade) and have been pulling my hair out: Apparently I'm literally the only person on the entire internet experiencing these crashes, which affect literally every fullscreen or windowed OpenGL program I try to run with Reshade.

The symptoms:
The game launches to a black screen, plays it's music for a little bit, then either stops responding or crashes to a nonspecific error message and tells me to submit the logs and memory dumps to the game or program's developer (in one specific case). This only occurs in OpenGL games and programs, is almost entirely uniform in how it happens, happens with each launch of said program or game, only occurs when reshade is installed for that game, and has no solution save removing Reshade entirely. Variations on this script appear below.

Tested on:
Neverwinter Nights: Diamond Edition 1.69 (Result: Music, blackscreen, hang, not responding, crash)
Neverwinter Nights: Enhanced Edition 1.76 (Result: Music, blackscreen, hang, crash, error message and memory dump)
GZDoom 3.3.0 (Result: Black screen with startup log in front, music, hang, not responding, crash)

Things tried: Reinstalling graphics drivers with Device Driver Uninstaller (with and without Nvidia Experience), tweaking with Nvidia Inspector (just in case overlays needed to be allowed for all types at the driver level for reshade to work), double-checking the graphics card being used (I run a nvidia optimus setup- this works fine with reshade for directx games, but only if the Nvidia GPU is selected for that game).

Hardware specs:
ASUS ROG GL551JW (Laptop)
16 GB DDR3 Ram
Intel Core i7 4720HQ (2.60 GHZ Default, 3.60 GHZ Turbo, 6MB Cache)
GPU 1 (Not Used For Gaming): Intel HD Graphics 4600
GPU 2 (Switched to via Nvidia Optimus when gaming): Nvidia Geforce GTX960M (2048 MB Cache)

While this computer is FAR from beefy or beastly, it STILL should reasonably be able to handle running old OpenGL games that already work without Reshade, once Reshade is installed. These crashes make no sense to me and I have no clue what's causing them. This is even happening on FRESH installs of Reshade, for games that are having Reshade installed to their directories for the first time!
Last Edit: 4 weeks 2 days ago by Ah_Ftagn.
The administrator has disabled public write access.

Reshade causes all opengl games to crash on launch 4 weeks 2 days ago #2

Hi

Which Reshade Version do you use ?

Make sure too , do you have no Overlay , Capture Tools open , like MSI Afterburner , DXTory , Action , OBS/Studio , Bandicam etc.

It is not so , that this Tools , cause a Crash with Reshade , but in some diff. combinations , it can mayby

I have too some Trouble with GzDoom , when OBS Studio is running , without OBS it works without problems !
im still search , a solution to fix my Captures !

Last Edit: 4 weeks 2 days ago by TP555.
The administrator has disabled public write access.

Reshade causes all opengl games to crash on launch 4 weeks 2 days ago #3

+With or without Discord, Steam, or any other program that has an overlay of any type over the rendering, I get the exact same results: Crashes.

+I do not use game capture tools, though I have experimented with them in the past. I couldn't get them to work (that's a discussion for another time).

+This crash is specific to OpenGL games, but a similar crash is experienced when using Reshade with DirectX 10+ games, unless I rename the DLL and INI from DXGI.(Ext) to something like "d3d11.(Ext)" (Example is for DirectX 11 games). Under any circumstances I have tested (including using overlay programs, launching through steam etc), DirectX 10+ games I have renamed the DLL and INI files for Reshade for... work perfectly, including the full function of Reshade working perfectly.

Generally when playing video games, only the game is in my taskbar, and the following are in my system tray:
+Steam
+Bluetooth Devices
+Asus Smart Gesture (Laptop touchpad control software - I use it to disable the touchpad)
+The Windows Defender icon
+Dropbox
+The wifi icon
+The sound mixer icon
+the battery level/charge status icon
+Process Lasso (I use it to alter process priorities, affinities and avoid non-game processes being CPU hogs, which grants me a boost to my framerate in games)
+(Occasionally) Ccleaner
+Occasionally (Discord)

The following are what shows up while the task manager is going, not counting the game I am running at the time and have alt-tabbed to check the task manager:
+Windows Explorer (Usually as a background process)
+Task Manager (Active, because it's being checked)
+Steam (Active or background)

These processes are also on the list, but are almost always background processes:
+Alcohol 52% ACHI controller (Registered copy- I use it to make digital copies of the playstation one games on my bookshelf for use on my phone)
+Antimalware service executable
+Asus Smart Gesture Center
+Asus Smart Gesture Helper
+Asus Smart Gesture Loader
+ATK Media (Asus Toolkit stuff- I think it manages the color composition/mood and brightness of my screen depending on what I am doing. Never had a problem running reshade at the same time as it before, and still don't when using DirectX based games)
+ATKOSD2 (Probably connected to ATK Media)
+CCleaner (occasionally, when I forget to exit out of it)
+Com Surrogate (2 of those)
+CTF Loader (Unsure what that is, I think it's a windows system process)
+Device Association Framework
+Dropbox. 3 separate processes of it in fact.
+Dropbox Service
+Dropbox Update
+Freelan Service (Hamachi stuff)
+GFNEXSrv (Connected to ATK Media)
+Hamachi Client Tunnelling Engine (Again, Hamachi stuff)
+HControl (Curious what this is. I think it's from some hotkey software. Voicebot maybe?)
+HD Audio Background Process (Realtek Audio Driver program, appears twice)
+Host process for setting synchronization.
+Host process for windows tasks.
+Three separate IGFX module processes - These are probably from the Intel GPU, AKA the one I don't use for gaming.
+3 separate Intel Pro/set processes for different things, with different names.
+An intel wireless bluetooth service process
+Something called LMIGuardianSvc
+Message Queuing service.
+Microsoft realtime inspection service
+Microsoft Windows Search Indexer
+MSS CS Connectivity Service
+2 64 bit "Nvidia Container" processes, and one 32 bit one.
+OriginWebHelperService (Origin is not actively running while this is on, usually)
+PnkBstrA.exe (Punkbuster? Didn't know I had anything with that anti-cheat in it)
+PresentationFontCache
+Process Lasso Management Engine
+Process Lasso User Interface
+Realtek HD Audio manager
+Cortana (3-process group)
+2 of "Runtime Broker"
+Sink to receive asynchronous callbacks for WMI client applications
+SMSvcHost
+Spooler Subsystem App
+Starwind iSCSI Target (Alcohol Edition) - Obviously has to do with Alcohol52% which as mentioned I pretty much just use to put PS1 games on my phone using the actual physical disk..
+Steam Client Service (32 bit)
+System Guard Runtime Monitor Broker Service
+System Settings Broker
+Usermode Font Driver Host (2 instances)
+Windows Defender Notification Icon
+Windows Security Health Service
+Windows Shell Experience Host
+Windows Wireless LAN 802.11 Extensibility Framework
+WMI Provider Host (2 instances)

Additionally, 89-91 windows processes on average are on the list. This group counts literally anything that is packaged as part of Windows 10 Home Edition X64
Last Edit: 4 weeks 2 days ago by Ah_Ftagn. Reason: Added a full list of processes usually running, so that they can be ruled out by anyone who cares to try.
The administrator has disabled public write access.

Reshade causes all opengl games to crash on launch 4 weeks 2 days ago #4

If there is a way to activate debugging in Reshade without having to successfully launch the game with it, I would like to know so that I can post the following:

+A debug log from Reshade
+A debug log from Neverwinter Nights: Enhanced Edition (An OpenGL based game using a modernized version of the engine from the original bioware release)
+The "Minidump" file from the Reshade OpenGL crash, when it occurs in Neverwinter Nights: Enhanced Edition.
+A full screenshot of each tab in the primary executable (nwmain.exe)'s properties window, arranged into a single image.

In the format of a zip file, since those can be opened by literally anyone with windows or most open source forms of archiving software.
Last Edit: 4 weeks 2 days ago by Ah_Ftagn.
The administrator has disabled public write access.