Welcome, Guest.
Username: Password: Remember me

TOPIC: Glass not recognised as transparent (for dof)

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #1

I've been trying to help someone who is experiencing problems with dof in The Sims 4. The depth buffer seems to be working correctly for them (they showed me a picture with display depth enabled), but glass windows are treated as solid objects. This isn't happening for the majority of players who use ReShade (including me).

Here are two pictures to illustrate (the window on the right has no glass and is just an opening in the wall):

Warning: Spoiler! [ Click to expand ]


In the top picture you can see dof is applied through the window opening on the right, but not on the left. In the bottom picture you can see the same scene with the display depth shader enabled.

They have tried several recent versions of ReShade.

Does anyone have any experience of this type of problem? Might there be a solution? It seems obvious the glass isn't being recognised as transparent, but whether that's to do with a faulty glass shader in-game, or a mesh problem, or a ReShade-related problem I don't know, and as I say this isn't affecting the majority of ReShade users of the game as far as I can tell.

(I've asked the person to test with as many different windows as possible to rule out it being a single mesh issue, and will update.)
Last Edit: 3 months 2 weeks ago by amoebae.
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #2

The glass is getting treated as a solid object. This also happens in many other games. This has to do how the game renders transparent objects. No solution and nothing seems wrong in this case.
My GitHub page where you can get the Latest release of SuperDepth3D github.com/BlueSkyDefender/Depth3D

My PayPal Me Link If you like to donate paypal.me/BlueSkyDefender

Also my steam page steamcommunity.com/id/BlueSkyDefender

Discord Server discord.gg/W2f7YhX
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #3

This was my first thought, but it's only happening to a small handful of people. Wouldn't you expect it to happen to everyone? Glass is treated as transparent for me (i.e. the background is blurred through it).

Edit: see it working as expected in my game (pic 1 = dof off, pic 2 = dof on, pic 3 = display depth)

Warning: Spoiler! [ Click to expand ]


You can see we both tested it with the same window mesh.
Last Edit: 3 months 2 weeks ago by amoebae.
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #4

in your first post, the view in the window is actually a texture painted on the window itself. in your second post, the window is actually functioning as a window. or in other words, the "fake" window in your first post has no depth data, because there's nothing there. to ReShade, it might as well just be an opaque wall.
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #5

It's the same window mesh though.

Trust me, your explanation is precisely what I explained to this person when they first asked me about this, because I never use dof through a window I just assumed it would be like that for everyone.

Here's my initial reply to them last Thursday:

Warning: Spoiler! [ Click to expand ]


However, they then showed me a picture by someone else where it was working. So I tested it myself and sure enough it works for me too. With the same mesh that doesn't work for the person with the problem. It's the same window we're both using, with different results. This is why I'm so confused.
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #6

Updating to say this issue is now fixed for the person who had it.

We don't know how it got fixed. They uninstalled ReShade through frustration, bought a new game expansion, and then on a whim reinstalled ReShade, and now it works.

Four things:

1) They had previously uninstalled and then installed several versions of ReShade in an attempt to fix this, so I don't know what was different this time if uninstalling and reinstalling was the cause of the fix.

2) They had previously repaired the game through Origin, which didn't fix it, so it's unlikely downloading and installing the new expansion forced a re-downloading of previously corrupted files that the repair didn't.

3) There's nothing in the game expansion that is an obvious fix, because dof has been working as expected for most other people since the beginning, regardless of what packs and expansions they have installed. The only thing I can think of here is a mismatch between patch version and the (absence of the) expansion had some unforeseen effect on the glass shader or window mesh transparency. That shouldn't happen, but when is anything to do with code straightforward?

4) I hope it's clear now this wasn't, as I explained three times, a simple "dof won't work through windows because it's a solid surface, suck it up" issue.
Last Edit: 3 months 2 weeks ago by amoebae.
The administrator has disabled public write access.

Glass not recognised as transparent (for dof) 3 months 2 weeks ago #7

ReShade'd depth buffer detection is dependent on a lot of factors, such as camera location, graphics settings, ..., so that it may select different depth buffers for different people. Games often render transparent objects after the rest of the scene was rendered, so it can happen that for some people ReShade selects the depth buffer used for scene rendering and for some it selects the buffer that was used afterwards to render transparent objects (in which all transparent objects will appear as solid objects).
Cheers, crosire =)
The administrator has disabled public write access.