Welcome, Guest.
Username: Password: Remember me

TOPIC: Crash at launch with DX9 games

Crash at launch with DX9 games 2 months 4 weeks ago #1

Whenever I install ReShade onto a DX9 game, if I try to launch the game it'll just fail to work. The game will show that it's running on Steam and then terminate without opening anything. Even with the Steam and nVidia overlay disabled this occurs.

To note, this ONLY happens with DX9 games. As a test I tried using Reshade on Shadow of Mordor, a DX11 game, and that worked without issue.


edit: Problem solved. Disabling Fullscreen Optimizations on DX9 titles on Windows 10 build 1803 is what caused the issue.
Last Edit: 2 months 3 weeks ago by ChaosBahamut.
The administrator has disabled public write access.

Crash at launch with DX9 games 2 months 3 weeks ago #2

To add to this:

Windows 10 v1803 with the "Disable fullscreen optimizations" option enabled have issues with some injectors using dxgi.dll and d3d9.dll as the injection point. This issue affects both ReShade and Special K, and most likely other injectors when using those names as well. However SweetFX (using d3d9.dll) is seemingly not affected.

For those of you unaware, the Windows 10 "fullscreen optimizations" are now seemingly the new "default" mode of the operating system, and disabling those invokes Windows 10 v1803's application compatibility engine and the appropriate shims.

Anyway, long story short, something goes wrong when using "Disable fullscreen optimziations" and injectors using d3d9.dll or dxgi.dll. The below issues happens with both ReShade and Special K:

* dxgi.dll - This will result in the fullscreen optimizations not actually being disabled. The application compatibility engine will be evoked, and loaded, but the game will not actually run in the classic exclusive fullscreen mode. It will instead still use the new fullscreen optimizations. This can easily be confirmed using a volume media key on a keyboard, which will cause Windows 10's volume bar to appear in the corner which it wouldn't if the fullscreen optimizations were actually disabled.

* d3d9.dll - This will, as in this thread, simply result in the game not launching at all. Instead Event Viewer will log a crash of some kind.

Both issues can be worked around by either unchecking "Disable fullscreen optimizations", or by using an alternate supported injection path (such as d3d11.dll for D3D11 games).
The administrator has disabled public write access.

Crash at launch with DX9 games 2 months 3 weeks ago #3

I'm having the same issue as OP, but unchecking "Disable Fullscreen Optimizations" didn't have any effect. Is there anything else that could be causing this issue?

EDIT: I found the problem. Although i had unchecked "Disable Fullscreen Optimizations" for the game's executable, that option was enabled for Steam.exe. Unchecking the box in Steam.exe's compatibility settings seems to have solved the problem.
Last Edit: 2 months 3 weeks ago by android927.
The administrator has disabled public write access.