world of warcraft 64b dx11 win7

More
5 years 9 months ago - 5 years 9 months ago #1 by ninjafada
i have a problem with wow in dx11 64bits mode

the game starts and i have a black screen i can hear the music, i press enter and the game load my selected character
if i disconnect and go back to the character selection screen i now have a screen with the list of all my guys, but the 3D model in the center is absent leaving a black hole

here is the log: pastebin.com/vYP5yrjf
Last edit: 5 years 9 months ago by ninjafada.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #2 by Aeg
Replied by Aeg on topic world of warcraft 64b dx11 win7
Same problem on windows 8.1 with wow 64bits dx11.
Login and character selection screen are black for all "3d stuff", but once in the game everything works.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3 by crosire
Replied by crosire on topic world of warcraft 64b dx11 win7
May be fixed with 0.12.0 now, probably a similar issue Ryse had.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #4 by Arioch
Replied by Arioch on topic world of warcraft 64b dx11 win7

crosire wrote: May be fixed with 0.12.0 now, probably a similar issue Ryse had.


I can confirm that the new beta release fixed this issue. I am glad to be able to inject effects into the 64-bit version of the DX11 renderer finally.

On a side note, I notice that enabling Reshade drops performance about 20% or so in this game. Is this to be expected and might performance improve on future releases?

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago - 5 years 9 months ago #5 by crosire
Replied by crosire on topic world of warcraft 64b dx11 win7

Arioch wrote: On a side note, I notice that enabling Reshade drops performance about 20% or so in this game. Is this to be expected and might performance improve on future releases?

Here's a thread about this =)
Last edit: 5 years 9 months ago by crosire.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #6 by ninjafada
Replied by ninjafada on topic world of warcraft 64b dx11 win7
oh great news !
gonna test that, about perf drop no problem the game run at 120fps most of the time ^^ and the final version will be tuned

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #7 by ninjafada

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #8 by ninjafada
Replied by ninjafada on topic [not solved] world of warcraft 64b dx11 win7
same problem with last build 0.13.1.666
and sometime some weird things, like my hairs rotated 180°


pastebin.com/rnjgN5Tq

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago - 5 years 9 months ago #9 by crosire
Replied by crosire on topic [not solved] world of warcraft 64b dx11 win7

ninjafada wrote: and sometime some weird things, like my hairs rotated 180°

Well, that's something. Let's call it "feature".
Just kidding. Could you check if the same happens without a shader loaded (rename/remove the .fx file and start the game + ReShade without. A text in the top left should indicate that nothing was loaded)? =)
Last edit: 5 years 9 months ago by crosire.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #10 by ninjafada
Replied by ninjafada on topic [not solved] world of warcraft 64b dx11 win7
yes same problem without shader loaded

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #11 by Eddy Stylez
Replied by Eddy Stylez on topic [not solved] world of warcraft 64b dx11 win7
I'm using the latest version of reshade and am also experiencing the login screen bug. Character is invisible, and background is distorted. Once I log in game everything seems to be running fine though. Wonder what's causing this?

Please Log in or Create an account to join the conversation.