OpenGL Uniform Buffer issue

More
4 years 2 months ago - 4 years 2 months ago #1 by VitorMac10 OpenGL Uniform Buffer issue was created by VitorMac10
Hello, im new to this forum, and I joined to share my experience with reshade
I am a game developer and I usually make things using OpenGL. I always used Reshade to test the performance of my game, and yesterday, after implementing Uniform Buffers in GLSL, Reshade simply doesn't work, before that, it was working fine
I get some weird flashing screen and all the rendering is messed up if I enable any effects
here some screenshots of the glitch:

imgur.com/9jcf1mG
imgur.com/b6d2heJ

I made some proper tests to my code, and figured out that using GL_UNIFORM_BUFFER causes this issue. Shaders are properly configured and working fine with version 420 core

I would be glad if someone help me with this, thanks anyways xD
Last edit: 4 years 2 months ago by VitorMac10. Reason: links not showing up :v

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #2 by crosire Replied by crosire on topic OpenGL Uniform Buffer issue
ReShade should not affect bindings. It resets them to the previous state after finishing rendering. Try to reset your OpenGL state every frame anyway. Also make sure drivers are up-to-date.

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.