Welcome, Guest.
Username: Password: Remember me

TOPIC: ut2k4-win64 issues with

ut2k4-win64 issues with 2 months 1 day ago #1

Seems like Reshade recognizes UT2004-64 bit patch as dx8, I checked underhood of .exe file of ut2004 64 bit and it says d3d9.dll.
But reshade installs dx9 hook.
Seems like its first versions of dx9, still its dx9 implementation into game.

checked with cff explorer.
The administrator has disabled public write access.

ut2k4-win64 issues with 2 months 1 day ago #2

lukonja wrote:
Seems like Reshade recognizes UT2004-64 bit patch as dx8, I checked underhood of .exe file of ut2004 64 bit and it says d3d9.dll.
But reshade installs dx9 hook.
Seems like its first versions of dx9, still its dx9 implementation into game.

checked with cff explorer.
It's D3D9 :)
But it's really a "beta" version, never got the appropriate support.

UT 2004 64 bit -> D3D9
UT 2004 32 bit + dgVoodoo2 -> D3D11
UT 2004 32 bit + Crosire wrapper -> D3D9
Last Edit: 2 months 1 day ago by lowenz.
The administrator has disabled public write access.

ut2k4-win64 issues with 2 months 1 day ago #3

There is no dedicated DX9 hook, it's all the same ReShade DLL. There are 2, one for 32 bit and one for 64, they just get renamed according to the API. So in case the installer mistakens the API level, just rename the file.
Last Edit: 2 months 1 day ago by Marty McFly.
The administrator has disabled public write access.

ut2k4-win64 issues with 2 months 16 hours ago #4

lowenz wrote:
lukonja wrote:
Seems like Reshade recognizes UT2004-64 bit patch as dx8, I checked underhood of .exe file of ut2004 64 bit and it says d3d9.dll.
But reshade installs dx9 hook.
Seems like its first versions of dx9, still its dx9 implementation into game.

checked with cff explorer.
It's D3D9 :)
But it's really a "beta" version, never got the appropriate support.

UT 2004 64 bit -> D3D9
UT 2004 32 bit + dgVoodoo2 -> D3D11
UT 2004 32 bit + Crosire wrapper -> D3D9

This explains alot. They probably used same calls and just half implemented vertex and pixel shaders, it explains bugs with shaders.

Question, where can i find proper D3D9 wrapper I saw you made/compiled one. Possible that you PM me that?
Can you change pixel and vertex shader model to 2.0 or above?
I wanna bring out maximum of win-64-bit patch, like HardwareT&L and HardwareVS. I know 9.1c is not possible, but atleast maximum out of what it uses would be nice.
To understand it, I have gtx 1080 here, I am using old sweetfx with dx9 hook from crosire wrapper, it works "ok" but I cansee graphical bugs in main menu... with enabled or disabled sweet fx, its very buggy version, only thing I use ingame are sharpness + fxaa, cause it makes big maps so clean.
But problem is its OVERLAY, so it messes up everything. And newest reshade is annoying, when I go alt+tab, it "reconstructs" overlay everytime, and it works same as 5 years older one.
The administrator has disabled public write access.

ut2k4-win64 issues with 2 months 10 hours ago #5

*Crosire wrapper: github.com/crosire/d3d8to9/releases
*dgVoodoo 2 last WIP: www.vogons.org/viewtopic.php?p=696238#p696238
*Fixed MicroSoft D3D8 for Win10 (choose the right Win10 version in the package): www.vogons.org/viewtopic.php?f=8&t=47772
Last Edit: 2 months 10 hours ago by lowenz.
The administrator has disabled public write access.
The following user(s) said Thank You: lukonja

ut2k4-win64 issues with 2 months 10 hours ago #6

An you can use WineD3D too (->OpenGL)!

fdossena.com/?p=wined3d/index.frag
Last Edit: 2 months 10 hours ago by lowenz.
The administrator has disabled public write access.
The following user(s) said Thank You: lukonja

ut2k4-win64 issues with 1 month 3 weeks ago #7

lowenz wrote:
*Crosire wrapper: github.com/crosire/d3d8to9/releases
*dgVoodoo 2 last WIP: www.vogons.org/viewtopic.php?p=696238#p696238
*Fixed MicroSoft D3D8 for Win10 (choose the right Win10 version in the package): www.vogons.org/viewtopic.php?f=8&t=47772

The crossire wrapper is d3d8? I need d3D9 64 bit one... standalone, without reshade. To work with the game.

Others I didn't bother dling, cause they are for 32 bit version :/
Last Edit: 1 month 3 weeks ago by lukonja.
The administrator has disabled public write access.

ut2k4-win64 issues with 1 month 2 weeks ago #8

Bumping this thread, cause this guy up was wrong.

UT2004-64-bit uses DX9.0b. And Reshade works fine.

So what is big "guy was wrong" solution.

Game is starting windowed instead full screen and solution implies to one of mistakes from Windows 10 itself, (Microsoft).

The API call is Windowed on Win10 64 bit dx9.0b, instead fullscreen. And thats it...
There are links to this in google search... takes 10 seconds, but I don't think I am allowed to post any of them so enjoy.
The administrator has disabled public write access.

ut2k4-win64 issues with 1 month 2 weeks ago #9

Can you read?

UT 2004 64 bit -> D3D9
UT 2004 32 bit + dgVoodoo2 -> D3D11
UT 2004 32 bit + Crosire wrapper -> D3D9

And of course 32 bit version is D3D8 (it's why we need wrappers or a fixed MS d3d8.dll you can find on vogons forum)

Crosire wrapper without reshade is here: github.com/crosire/d3d8to9/releases
Last Edit: 1 month 2 weeks ago by lowenz.
The administrator has disabled public write access.

ut2k4-win64 issues with 1 month 1 week ago #10

lowenz wrote:
Can you read?

UT 2004 64 bit -> D3D9
UT 2004 32 bit + dgVoodoo2 -> D3D11
UT 2004 32 bit + Crosire wrapper -> D3D9

And of course 32 bit version is D3D8 (it's why we need wrappers or a fixed MS d3d8.dll you can find on vogons forum)

Crosire wrapper without reshade is here: github.com/crosire/d3d8to9/releases

wait so you are saying that you can hook 32bit to d3d11? Can you show example and how you did it? I can't make it work with the game.
The administrator has disabled public write access.

ut2k4-win64 issues with 1 month 1 week ago #11

The administrator has disabled public write access.
The following user(s) said Thank You: lukonja