AC: Unity - Depth buffer output shows black screen

More
5 years 8 months ago #1 by jim2point0
I've had a lot of success trying depth of field in various games, but noticed it didn't work at all in Unity. I turned on "USE_DEPTHBUFFER_OUTPUT" in Master Effect, but that just gives me a black screen. I have a feeling that's not normal.

Just figured I'd point that out. Depth of Field could actually help out a ton with that games LoD problems.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #2 by crosire
Could you check how much network activity the game is having? To do that add "#pragma reshade statistics" to the shader (doesn't matter where) and check the "Network" field of the new statistics window popping up in the upper right corner. It should be zero most of the time or otherwise ReShade may decide to label the game multiplayer and disable the depthbuffer.
If that is not the case, enable tracelogging and check if the log contains any messages similar to "Adding depthstencil ...." and "Switching to depthstencil ...".

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #3 by jim2point0
Network activity was a constant 0 bytes up \ down.

I checked the "dxgi.log" file and didn't see anything like what you said.

Is tracelogging something different than that? If it is, how do I enable that?
Last edit: 5 years 8 months ago by jim2point0.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #4 by Nekrik
Just Rename the "dxgi.log" to "dxgi.tracelog"
Also i think that if reshade gets depthbuffer source information you can see info like this in tracelog:
06/01/2015 18:12:07,625 | TRACE | Adding depthstencil 14E7DF60 (Width: 1600, Height: 1024, Format: 75) to list of possible depth candidates ...
and like this:
06/01/2015 18:12:50,697 | TRACE | Switched depth source to depthstencil 14E7DF60
Last edit: 5 years 8 months ago by Nekrik.

Please Log in or Create an account to join the conversation.