Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] 3d LUT no longer works in latest version

3d LUT no longer works in latest version 1 month 3 weeks ago #1

Hi
I've been using 3d lut created in displaycal GUI for years with reshade. I simply put the generated LUT files in the parent game directory; run the game and it appears alongside other installed FX like adaptive sharpening.
However with the new reshade it doesn't show anymore in games like Battlefield 3.
Is this an issue or is there a new way to install it now?
This is how I historically created my 3d out with a colorimeter.www.avsforum.com/forum/139-display-calib...s-under-windows.html

Thanks for reading
Last Edit: 1 month 3 weeks ago by Pixel.
The administrator has disabled public write access.

3d LUT no longer works in latest version 1 month 2 weeks ago #2

Anyone?
The only game this method works in is in Division, everything else does not bring up the colour.fx
The administrator has disabled public write access.

3d LUT no longer works in latest version 1 month 2 weeks ago #3

There is a LUT shader in 3.X. Here's a guide with some information on how to configure it (along with information on how to manually create a LUT, but you can skip that if you use a tool like DisplayCAL): reshade.me/forum/shader-discussion/3179-...correction-the-guide.
Cheers, crosire =)
The administrator has disabled public write access.

3d LUT no longer works in latest version 2 weeks 5 days ago #4

crosire wrote:
There is a LUT shader in 3.X. Here's a guide with some information on how to configure it (along with information on how to manually create a LUT, but you can skip that if you use a tool like DisplayCAL): reshade.me/forum/shader-discussion/3179-...correction-the-guide.

I'll check it out but the latest v4 Reshade also broke 3d luts working in Division. The new method seems really convoluted compared to how it used to work, which was a simple drag and drop the 3dlut and fx files into the game directory. Why change something which wasn't broken?

Edit - I tried it and the whole screen goes red. I added the lut.fx shader, renamed the displaycal generated shaders to LUT.png and left the colorlookuptable.fx folder inside the Textures folder and everything loads red. I'm at a loss.
Last Edit: 2 weeks 5 days ago by Pixel.
The administrator has disabled public write access.

3d LUT no longer works in latest version 2 weeks 4 days ago #5

This is what it looks like in game
imgur.com/iFml8XQ

You're now the proud owner of a customized LUT image. There's two ways to use it in ReShade:
1) If you have a different "textures" folder for each game, you can simply replace the original "lut.png" file and turn on LUT.fx in ReShade


I renamed and replaced the generated LUT.png from DisplaycalGUI and replaced it with the one in the textures folder
imgur.com/Saeslcu

LUT.fx works fine for me in 4.0.2. Could you post the ReShade settings from a game where it doesn't work? (the [GENERAL] section from the ReShade.ini and the name + path from your LUT)

- [GENERAL]
TextureSearchPaths=.\reshade-shaders\Textures
EffectSearchPaths=.\reshade-shaders\Shaders

imgur.com/O7FaUu4
Last Edit: 2 weeks 4 days ago by Pixel.
The administrator has disabled public write access.

3d LUT no longer works in latest version 2 weeks 2 days ago #6

Pixel wrote:
This is what it looks like in game

Looks like the used LUT is of the wrong size which lets the shader pick the wrong colors. By default the LUT size needs to be 1024x32 (32 tiles with a size of 32x32). If your LUT is of that size already and produces that result - then I have no idea what's wrong.
Last Edit: 2 weeks 2 days ago by Daodan.
The administrator has disabled public write access.
The following user(s) said Thank You: Pixel

3d LUT no longer works in latest version 2 weeks 1 day ago #7

Daodan wrote:
Pixel wrote:
This is what it looks like in game

Looks like the used LUT is of the wrong size which lets the shader pick the wrong colors. By default the LUT size needs to be 1024x32 (32 tiles with a size of 32x32). If your LUT is of that size already and produces that result - then I have no idea what's wrong.

Hi thank you. Generating a new 3d lut with that size worked. However the game doesn't have as much pop as it used to. I guess it works for now but will check with Florian from DisplaycalGUI if there is another approach.
The administrator has disabled public write access.

3d LUT no longer works in latest version 1 week 5 days ago #8

I'm seeing some very odd effects when I (try to) apply my 3DLUT under 4.0.2:

RE6

My LUT is 4096 x 64 (64 tiles of 64x64 each) - can anybody see anything obviously wrong? I've tried every permutation of isreversed and isupsidedown to no avail. LUT.fx works flawlessly in v3.

Cheers,

M.
Last Edit: 1 week 5 days ago by Mark A.
The administrator has disabled public write access.