Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Some issues with 4.0

Important information for upgrading to version 4.0 3 weeks 3 days ago #1

I would like to share my experience with the upgrade to version 4.0.1
Many people report having their game crash and this can in some cases not be a problem of ReShade!

I have been broadcasting for years ReShade ready for use and adapted to the game Guild Wars and Guild Wars 2 so that it is installed correctly without complicated intervention and also be adapted to its operation with other addons that requires to do a chainload between them.
And the passage in 4.0.1, my game has done as I see for others, a big crash and even frozen on the bug report.

However, I had removed all third-party addons, all files had been updated.
Yes they must have thought about replacing the other files too.
EXCEPT !!!
the ReShade configuration file I kept from the previous version did not think that it will have a big impact and will avoid any reconfiguration.

THE PROBLEM COMES FROM THAT!

We must erase the old INI file (then named as ReShade, ex: if ReShade is named d3d9.dll then it is d3d9.ini, etc.)

Once cleared, and the game relaunched, everything goes well!

So I hope this will help players first test correctly to see if actually
The administrator has disabled public write access.

Important information for upgrading to version 4.0 3 weeks 3 days ago #2

Hum ReShade without chainload work now but with chainload, they crash again
dont know if some chainload is broken too
The administrator has disabled public write access.

Important information for upgrading to version 4.0 3 weeks 3 days ago #3

ReShade should never crash because of an old INI. They are compatible. If it does that is a bug and if you still have that config somewhere please upload it somewhere so I can debug.

Chainloading is not officially supported.
Cheers, crosire =)
Last Edit: 3 weeks 3 days ago by crosire.
The administrator has disabled public write access.

Important information for upgrading to version 4.0 3 weeks 3 days ago #4

um, though I can assure it, with the latest version, it caused a crash until I removed the previous file that I had renamed.
no one file delted, or modified.

This file contained this:
[INPUT]
KeyMenu=36,1,0,0
InputProcessing=2
KeyScreenshot=44,0,0,0
KeyEffects=19,0,0,0

[GENERAL]
PreprocessorDefinitions=RESHADE_DEPTH_LINEARIZATION_FAR_PLANE=1000.0,RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0,RESHADE_DEPTH_INPUT_IS_REVERSED=1,RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0
TextureSearchPaths=G:\Guild Wars 2\bin64\reshade-shaders\Textures
EffectSearchPaths=G:\Guild Wars 2\bin64\reshade-shaders\Shaders
CurrentPreset=0
PresetFiles=G:\Guild Wars 2\bin64\GuildWars2.ini
ShowClock=0
ScreenshotPath=D:\Pictures\Screenshots\Guild Wars 2
ScreenshotFormat=1
ShowFPS=0
PerformanceMode=1
TutorialProgress=5
NoReloadOnInit=0
FontGlobalScale=1.000000
SaveWindowState=0

[DX9_BUFFER_DETECTION]
DisableINTZ=0

[STYLE]
ColFPSText=0.205882,1.000000,0.000000
ColActive=1.000000,0.529412,0.200000
Alpha=0.750000
ColBackground=0.275000,0.275000,0.275000
ColText=0.800000,0.900000,0.900000
ColItemBackground=0.447000,0.447000,0.447000
Ok, i will stay on 3.4.1 for can use chainload with arcDPS and others
the chainload file used (not used with the crash of this post) : www.deltaconnected.com/arcdps/reshade_loader/

Thanks for the response, i will try some search or advanced rework for chainload if possible.
And i know this is not you who propose chainload ^^
Last Edit: 3 weeks 3 days ago by ReActif. Reason: just add text
The administrator has disabled public write access.

Important information for upgrading to version 4.0 3 weeks 3 days ago #5

So I pass for a stupid finished, but not serious I have to tell what happens to not that others get their post.

Thank you for your intervention, it pushed me to retry starting from scratch and playing on the various chainload that I know and strangely on the second attempt, everything worked.

I do not have the precise reason, for not having kept all the previous files but it would be possible that one of the shaders of the old version remained, I do not see that that could make sense.

But it is also possible that I confused the displacement version 32 and 64 (which would be even more stupid)

In short, it works, I do not know if I can do it but otherwise the deletion of the post will avoid a mistake for others, because whatever the reason, it works in the end and with the chainload.

Thanks again for the job provided on ReShade
The administrator has disabled public write access.