Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Shader Paths no longer automatically found in 4.0

Shader Paths no longer automatically found in 4.0 3 weeks 2 days ago #1

By default when using the Reshade Installer it configs the Effect and Texture search paths to the following:

.\reshade-shaders\Shaders
.\reshade-shaders\Textures

The result is this:


Setting the paths to the FULL directory path fixes this:

D:\Games\Steam\steamapps\common\Warframe\reshade-shaders\Shaders
D:\Games\Steam\steamapps\common\Warframe\reshade-shaders\Textures



Not sure if this was intended or just a bug. The only tweak with my installation is I have to set the dxgi.dll to read only in order for it to work with warframe. So perhaps that is why this is occurring?
Last Edit: 3 weeks 2 days ago by a1chera_.
The administrator has disabled public write access.

Shader Paths no longer automatically found in 4.0 3 weeks 2 days ago #2

The game changes the working directory to something that is not the folder ReShade was installed to. ReShade doesn't handle that case for relative search paths. I'll have that fixed with the next update.
Cheers, crosire =)
The administrator has disabled public write access.

Shader Paths no longer automatically found in 4.0 3 weeks 2 days ago #3

crosire wrote:
The game changes the working directory to something that is not the folder ReShade was installed to. ReShade doesn't handle that case for relative search paths. I'll have that fixed with the next update.

Interesting. I thought the .\ before the folder name meant that it searches for the folder where ReShade was installed. Or maybe I forgot that in ReShade 3.0 it would point to the full directory path without the .\ before it? This is what my game folder looks like.

Last Edit: 3 weeks 2 days ago by a1chera_.
The administrator has disabled public write access.

Shader Paths no longer automatically found in 4.0 3 weeks 2 days ago #4

Update to 4.0.2. It will work as you expected.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: BlueSkyKnight, a1chera_