Welcome, Guest.
Username: Password: Remember me

TOPIC: LUT issue with ver 4.0.2

LUT issue with ver 4.0.2 11 months 3 weeks ago #1

Hello,

This is my 1st time posting here as I haven't found a solution anywhere else.
Yesterday I have updated my Reshade version to 4.0.2. My previous version was just before this new update.
And since this new version, my LUT shader doesn't have effect anymore... I have of course tried to modify the setting of this shader but nothing. I have tried to uninstall it and tried to install an old version I still had on a folder (3.0.6) but seems it doesn't recognize shaders in my folder anymore, so it's all empty when I open the Reshade window in-game.

Does anyone have the same issue ? I would really appreciate any help.

Thanks !
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 3 weeks ago #2

Yes I have the same issue using my color correct LUT to load using LUT.fx shader or the one that displaycalgui generates.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 3 weeks ago #3

LUT.fx works fine for me in 4.0.2. Could you post the ReShade settings from a game where it doesn't work? (the [GENERAL] section from the ReShade.ini and the name + path from your LUT)
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #4

(Also posted in similar thread re: v4)

I'm seeing some very odd effects when I (try to) apply my 3DLUT under 4.0.2:

RE6

My LUT is 4096 x 64 (64 tiles of 64x64 each) - can anybody see anything obviously wrong? I've tried every permutation of isreversed and isupsidedown to no avail. LUT.fx works flawlessly in v3.

Cheers,

M.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #5

There are two ways to fix this. You can either scale your LUT down to 1024x32 (which is the default size LUT.fx expects) or you tell LUT.fx the size of the used LUT. This can be done by adding fLUT_TileSizeXY=64 and fLUT_TileAmount=64 to the global preprocessor definitions.

[edit]
Didn't notice that you have already done this (setting fLUT_Tile* to 64). Well, the only thing that comes to mind is that the colors in your LUT are encoded the wrong way.
Last Edit: 11 months 1 week ago by Daodan.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #6

If the modifiers have been keyed in properly (setting in left box and value in right), it looks like I'll have to stick with v3.4.1 :(.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #7

Could you post a link to your LUT so I can try it out and maybe see whats wrong?
The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #8

The administrator has disabled public write access.

LUT issue with ver 4.0.2 11 months 1 week ago #9

I just tried the LUT out and it looks fine. One thing I noticed though is that if you change the LUT size to 64x64x64 and point the shader to the neutral 32x32x32 LUT the result looks exactly the same as in your screenshot (these red/black color bands). Do you have multiple texture search paths in your settings? It could be the case that there is more than one "lut.png" and ReShade takes the first (32x32x32) it finds. (Generally I would recommend to give custom LUT's a distinctive name to prevent that from happening)
The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #10

Hello,

As I were quite impatient I re-installed 3.4.1 until I could find a solution.
I looked at your replies, and something I don't understand.

In my textures files, my LUT texture is 1024x32.
I also checked my ReShade.ici file in the [GENERAL] section : there's no specific path for LUT, but the Effect Search path and Texture Search path, and they both correspond to the right files.

Where should I check?
Thank you for your help :)
The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #11

Lanvali wrote:
...there's no specific path for LUT, but the Effect Search path and Texture Search path, and they both correspond to the right files.
Where should I check?
Which LUT is used is decided from within the LUT shader:
#ifndef fLUT_TextureName
	#define fLUT_TextureName "lut.png"
#endif
#ifndef fLUT_TileSizeXY
	#define fLUT_TileSizeXY 32
#endif
#ifndef fLUT_TileAmount
	#define fLUT_TileAmount 32
#endif
You can override these values with the global preprocessor definitions (the fLUT* ones):

Try naming your LUT a unique name and add that to the preprocessor definitions.
Then enable the LUT technique and check in the Log tab for any errors.
If you see something like that
ERROR | > Source "myLUT.png" for texture 'V__texLUT' could not be found in any of the texture search paths.
you need to check if there's any error in the search paths and/or the LUT name.
Last Edit: 9 months 3 weeks ago by Daodan.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #12

Hey, thank you for your reply !Daodan wrote:
You can override these values with the global preprocessor definitions (the fLUT* ones):
Try naming your LUT a unique name and add that to the preprocessor definitions.
Then enable the LUT technique and check in the Log tab for any errors.
If you see something like that
ERROR | > Source "myLUT.png" for texture 'V__texLUT' could not be found in any of the texture search paths.
you need to check if there's any error in the search paths and/or the LUT name.

I tried it with the name "myLUT.png" like your picture and it still found it in the textures files, but there's still no effect.
In the statistics tab, it showed this for LUT:

Not sure if it can help...

I also tried with the name "lut-pink.png" but it didn't work...
ERROR | > Source "lut-pink.png" for texture 'V__texLUT' could not be found in any of the texture search paths.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #13

Not sure why it doesn't work for you but here's a setup with a greyscale LUT that works.
Maybe it helps you.



The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #14

Daodan wrote:
Not sure why it doesn't work for you but here's a setup with a greyscale LUT that works.
Maybe it helps you.
I didn't have the lut-bw files so I made one based on the original one.
And the thing is, it worked ? My screen became greyscale when I activated it after I changed the fLUT_Texturename to this files.
But the luminosity doesn't change at all like before.
I think Reshade works but the LUT doesn't work like before (version 3.4.1) but I don't know why...
The administrator has disabled public write access.

LUT issue with ver 4.0.2 9 months 3 weeks ago #15

I tried to figure out the difference between 4.0.2 LUT and 3.4.1 LUT, and it seems like I had both LUT and LUTAtlas files, and the difference is made only if I have them both files available.

In 3.4.1 LUT file, there are these lines in more than 4.0.2 one :
Warning: Spoiler! [ Click to expand ]


But if I add these lines like how there are disposed in 3.4.1 lut file, when I launch my game it says "failed to compile" or something like that.

Any clue? :(
The administrator has disabled public write access.

LUT issue with ver 4.0.2 8 months 1 week ago #16

I have the same issue. It wont read anything bigger that 1024X32 without corrupting.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 8 months 1 week ago #17

The texLUT's "Width" and "Height" is calculated values.
Modify values to equals by calculated of fLUT_TileSizeXY and fLUT_TileAmount for your created image.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 8 months 1 week ago #18

seri14 wrote:
The texLUT's "Width" and "Height" is calculated values.
Modify values to equals by calculated of fLUT_TileSizeXY and fLUT_TileAmount for your created image.
I did that. I used Lightroom to make my LUT. I copied what it said in that shader. Makes everything not right.
The administrator has disabled public write access.

LUT issue with ver 4.0.2 4 months 3 weeks ago #19

Try changing the 0.5 to 1.5 in this line.
float3 lutcoord = float3((color.xy*fLUT_TileSizeXY-color.xy+0.5)*texelsize.xy,color.z*fLUT_TileSizeXY-color.z);

Also, make sure there is no alpha channel on the lut. It increase the bit depth of the image, which could be a part of the problem. I hope that this is a lasting solution to the problem and not something I'll run into problems with later in the game I'm using it with.
Regards from:
Igni
The administrator has disabled public write access.