Welcome, Guest.
Username: Password: Remember me

TOPIC: game says enabled but zero effects

game says enabled but zero effects 1 year 10 months ago #1

Hi all,

I've downloaded ReShade 0.17.1 Public Beta with SweetFX 2.0 directly from the website. I also downloaded 'Neutral Shaders of Eternity 1.4' for Pillars of Eternity.

I'm really confused as this doesn't work like the old SweetFX config did - whenever I run ReShade setup to attach it to the game, it has to overwrite the Sweetfx_settings file, and when I load the game it shows the message and tells me in the upper left that it's running, but pressing scroll lock changes nothing, and I can't notice any visual difference?

I don't have a log file as I don't know where they are.. I did get this from my game folder though (it's a file named OPENGL32.txt)
pastebin.com/jrm4yB0k

Please help! I loved the old SweetFX but I'd like ReShade to work too.
The administrator has disabled public write access.

game says enabled but zero effects 1 year 10 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
The setup tool is just there to copy the files, you don't need it, you can do it just like old times too.
Copy over ReShade and SweetFX to your game directory. Rename ReShade32.dll to dxgi.dll (I guess, since the game seems to be running on Unity, which usually uses D3D11 as default on Windows) and copy your SweetFX preset into the SweetFX folder (that's the only difference here, SweetFX 2.0 has its settings file in the SweetFX subfolder and no longer the main directory).
Cheers, crosire =)
Last Edit: 1 year 10 months ago by crosire.
The administrator has disabled public write access.

game says enabled but zero effects 1 year 10 months ago #3

Hi Crosire, I did as you said to do.

Reshade and sweetfx were copied into the game directory, ReShade32.dll renamed to dxgi.dll. Preset copied into the SweetFX folder and renamed to SweetFX_settings to replace the default. Still not showing any changes nor working with scroll lock toggle :( here's the log from the attempt:
pastebin.com/yiwq0kMm
thanks in advance!
The administrator has disabled public write access.

game says enabled but zero effects 1 year 10 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
Try renaming to d3d9.dll or opengl32.dll instead.
Cheers, crosire =)
The administrator has disabled public write access.

game says enabled but zero effects 1 year 10 months ago #5

Latest log with d3d9.dll (game always says success and mentions that it's rendering in d3d9 by the way) - still no difference/no scroll lock change. Maybe i should just use the oldschool sweetfx? :(

pastebin.com/VTzM77YZ
The administrator has disabled public write access.

game says enabled but zero effects 1 year 10 months ago #6

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2536
  • Thank you received: 1452
Well, it works perfectly then. You may want to enable some extreme effect to see the difference (the ASCII one for example). Settings are in the game directory \SweetFX\SweetFX_settings.txt". The toggle buton is bugged in this version, so no wonder you can't switch it on/off =).
Cheers, crosire =)
The administrator has disabled public write access.