Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Dark Souls 2 SotFS crash on startup fix

Dark Souls 2 SotFS crash on startup fix 1 year 7 months ago #1

Not sure where to post this but I think it will be helpful for DS2 Scholar of the First Sin players.

So I recently experienced some odd crashes trying to use ReShade with DS2 SotFS. I used the ReShade Setup.exe that came with the ReShade Framework 0.17.1 release to create the ReShade files in the DS2 game directory. It placed the ReShade64.dll in there, named as dxgi.dll. At first I could start up the game just fine, but after exiting once I couldn't start the game again; it would crash within a second. I discovered that deleting the dxgi.log, which was created upon the initial startup of the game, oddly enough fixed the issue.
Basically this would mean that you would have to delete the dxgi.log every time before running the game, which bothered me. I found a topic on this site (that is now closed I think) that addressed a similar issue and was "solved" by running the DS2 exe as administrator (and optionally disabling the Steam Overlay). This didn't fix the problem for me!
In another topic about GTA V there seemed to be a similar issue and someone suggested renaming dxgi.dll to d3d11.dll, so I thought why not try it for DS2. And tadaa, it seems to be fixed now :cheer: It now creates a d3d11.log that does not need to be deleted, the game starts up just fine.

So yeah, basically the Setup tool incorrectly renames the ReShade64.dll to dxgi.dll when it should be d3d11.dll I guess? I figured this might have to do with the fact that there are two different versions of DS2 (DX9+DX11) now that share the same .exe name? But maybe this has nothing to do with it at all, I don't know what I'm talking about.

Anyway, this might help other DS2 SotFS players that are looking for solutions to their crashes, I spent a lot of time messing around with this little issue myself.
Last Edit: 1 year 7 months ago by Pretendeavor.
The administrator has disabled public write access.

Dark Souls 2 SotFS crash on startup fix 1 year 7 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2438
  • Thank you received: 1385
Thanks for putting this out =).

The setup tool does it right, they both work. It looks like Steam changed their way of hooking recently, which is no longer compatible to the current ReShade version (or it just never caused trouble until now). That particular issue is fixed with 0.18.0 though.
Cheers, crosire =)
The administrator has disabled public write access.

Dark Souls 2 SotFS crash on startup fix 1 year 7 months ago #3

Ah alright, thanks for clearing that up
The administrator has disabled public write access.