Unable to launch SWTOR with Reshade installed.

More
1 year 7 months ago - 1 year 7 months ago #1 by HylianSteel
I've been unable to launch SWTOR (Star Wars The Old Republic) with Reshade installed. Each time I try, I get this error.

The application was unable to start correctly (0xc0000005). Click OK to close the application.


removing Reshade lets me launch the game without issue.
SWTOR is a DX9 game and i've installed the dx9 redistributables too.
OS: Windows 10 version 1809 (OS Build 17763.292)
I think that this might be an issue Reshade and Win 10 version 1809 because apparently people running 7, 8.1, and earlier versions of 10 have no problems with it.

I've seen others complain about it on reddit so I don't think it's just me.
Last edit: 1 year 7 months ago by HylianSteel.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago - 1 year 7 months ago #2 by brazzjazz
Replied by brazzjazz on topic Unable to launch SWTOR with Reshade installed.
Hmm, you might either try renaming d3d9.dll to something else, such as dinput.dll, ddraw.dll. Or you might try using ReShade 3.4.1 (the last version before 4).

github.com/crosire/reshade-shaders/tree/...340a66495ac1ac059c85

Note, these are the 3.4.1 shaders that you will need because the installation exe will download the latest ( = wrong, 4.1.1) shaders .

Not sure whether the earlier executables are downloadable anywhere? Otherwise I may put it up somewhere for you to download.
Last edit: 1 year 7 months ago by brazzjazz.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #3 by HylianSteel
Replied by HylianSteel on topic Unable to launch SWTOR with Reshade installed.
Renaming has solved the crashes, but then Reshade doesn't actually load at all.
3.4.1 also gives out the same crash and error code as the latest release.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago - 1 year 7 months ago #4 by brazzjazz
Replied by brazzjazz on topic Unable to launch SWTOR with Reshade installed.
...have you tried different compatibility modes? Maybe that way Windows does not load problematic libraries, whatever of the fall update.
Last edit: 1 year 7 months ago by brazzjazz.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #5 by HylianSteel
Replied by HylianSteel on topic Unable to launch SWTOR with Reshade installed.
so far, compatibility modes have made no difference.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #6 by yoimdumbsry
Replied by yoimdumbsry on topic Unable to launch SWTOR with Reshade installed.
I've figured out a solution thanks to reddit. You need to make sure swtor.exe and launcher or any shortcuts DO NOT have run as admin enabled. any other compatibility settings should be fine. Also make sure to install reshade as DirectX10, not direct9. Weird, but it works and loads. Use the Home button on your keyboard to get into the reshade menu. Here is the reddit thread with even more info: reddit.com/r/swtor/comments/ag16ue/tutorial_reshade_lod_bias/ Good luck!
Last edit: 1 year 6 months ago by yoimdumbsry.
The following user(s) said Thank You: HylianSteel

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #7 by HylianSteel
Replied by HylianSteel on topic Unable to launch SWTOR with Reshade installed.
yoimdumbsry, that worked perfectly. I'm still quite confused on as to why since this is a dx9 game... but hey, i'll take it!

Please Log in or Create an account to join the conversation.