Issues w/ReShade 4.1 and FFXIV

3 years 7 months ago #1 by Darkfae Issues w/ReShade 4.1 and FFXIV was created by Darkfae

I did a check, and I couldn't find my exact issues having been posted, at least not with the 4.1 version of ReShade, so I'm making a new post on the matter.

I currently have two different issues with ReShade 4.1 and FFXIV.

Whenever I run ReShade with the DX11 client, I'll end up crashing. Sometimes this happens after hours of play, sometimes it happens only after a few minutes. Once I do crash, I can't actually get back into the game without crashing almost instantly unless I nuke ReShade, or run in DX9.

Some of this seems to be some sort of error in the DX11 coding for FFXIV, because it does happen sometimes when ReShade isn't installed. It just happens a hell of a lot more often with ReShade than not.

So, I am often having to run FFXIV in their DX9 mode. However, it seems I cannot get ReShade to work with DX9 at all. It just doesn't load with the DX9 client, even if I've installed it for DX9. I tried using a .dll file from here for DX9, and even that doesn't help. I also tried renaming the file for DX9 to dxgi.dll but that didn't help either.

I'll take a fix for either client, but I'd prefer the DX11 one. I use mods (which ironically aren't causing the crash, because I can play for ages with them without a problem), so I'd prefer to fix the DX11 client.

Thanks in advance for any time and effort put towards this issue!

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.