Some kind of bug with DC Universe Online ?

  • Posts: 4
1 year 4 months ago #1 by busylazyguy
When I use reshade I noticed it would intermittently work correctly and sometimes not. While playing around and clicking on buttons I noticed that if I reversed the depth input and flipped it back and forth a few times it would eventually click in and start working. I just thought you guys should be aware of that weird behavior so you can track down whatever is causing it and hopefully save someone a lot of time and frustration in the future. Thanks for the really neat tool it makes DCU Online bareable to look at.

Please Log in or Create an account to join the conversation.

  • Posts: 206
1 year 4 months ago #2 by Duran.te
From what I know this weird behaviour could be associated to the fact that, to avoid troubles, reshade automatically blocks all depth - depending effects in online games. In this case you can either get a modified version that unlocks it (at your own risk) or just not use depth shaders.

Please Log in or Create an account to join the conversation.

  • Posts: 4
1 year 4 months ago #3 by busylazyguy
If it was part of the code that blocks depth based on internet activity it would be nonfunctional all the time. It's not non functional all the time. It's just buggy as hell. I don't think this game is the type to benefit from any hacks but I do understand what you're getting at.

Please Log in or Create an account to join the conversation.

  • Posts: 206
1 year 4 months ago #4 by Duran.te
From FierySwordswoman's post Common Issues and Their Solutions :

FierySwordswoman wrote: Firstly, The Depth Buffer turns itself off during network activity to prevent exploitation of competitive multiplayer games. This causes depth-related effects to either flicker or not work at all, and *may* even apply to single-player games modes with weird internal server setups.


So, its intermittent / flickering property could be just explained like this.

Please Log in or Create an account to join the conversation.