Wolfenstein: The New Order crash with Reshade

  • Posts: 6
9 months 3 weeks ago - 9 months 3 weeks ago #1 by Amaratu
Wolfenstein: The New Order crashes with any Reshade version on Win10. Please offer any solution.
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

  • Posts: 433
9 months 3 weeks ago #2 by Martigen
You're in luck I still have this installed :)

I can confirm (trying it again now) it works fine with both Reshade 4.2.0 and 4.2.1. I haven't updated to 4.3 yet.

I'm running Windows 1809.

Not that the log shows much, but here's mine:
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

  • Posts: 6
9 months 3 weeks ago #3 by Amaratu
This versions don't work either. Other games on d3d11 works fine. I belive its something about opengl32.

Please Log in or Create an account to join the conversation.

  • Posts: 433
9 months 3 weeks ago #4 by Martigen

Amaratu wrote: This versions don't work either. Other games on d3d11 works fine. I belive its something about opengl32.

Well it does work, you can see above. There's something different about your system. What's your Windows 10 version? When you say crashes, what exactly happens?

Please Log in or Create an account to join the conversation.

  • Posts: 6
9 months 3 weeks ago #5 by Amaratu
My OS Windows 10 Home version 1803.

When you say crashes, what exactly happens?

I launch the game; loading starts and window just close without any message or smth.

Please Log in or Create an account to join the conversation.

  • Posts: 6
9 months 3 weeks ago #6 by Amaratu
Some new information. I tried to launch the game with integrate gp (use notebook) and reshade initializes fine. But stil dont work with discrete graphic card.

Please Log in or Create an account to join the conversation.

  • Posts: 433
9 months 3 weeks ago #7 by Martigen

Amaratu wrote: Some new information. I tried to launch the game with integrate gp (use notebook) and reshade initializes fine. But stil dont work with discrete graphic card.

Ah... so this is related to integrated/discrete on laptops. There have been some issues with using Reshade with these hybrid setups, I can't remember off the top of my head and don't have time now, but search there forums here.

Off the cuff I wonder when it's trying to initialise as OpenGL it's using the integrated cards OpenGL stacks instead of the discrete which the game is trying to utilise... (I have no idea how APIs are initialized so someone with more knowledge might have to chime in). Regardless there may be a solution somewhere in the forums already.

Please Log in or Create an account to join the conversation.

  • Posts: 6
9 months 3 weeks ago #8 by Amaratu
Ookaay I finally found solution. I disabled integrate gc in Device Manager and Reshade started to load. Just cant take why it worked. So ridiculous...
Anyway thanks for assistance! (=

Please Log in or Create an account to join the conversation.