Depth loss in Assetto Corsa Competizione

More
1 year 3 months ago - 1 year 3 months ago #1 by Jesped
There is some really strange problem with the depth buffer in Assetto Corsa Competizione (Unreal 4 engine - Reshade 4.3.0)

Some tracks "break" the depth buffer from the start, and the depth buffer doesn't recover to normal until game is fully restarted. :blink:

Let me explain in detail:

Some tracks the depth buffer works ok, like Monza here:
Warning: Spoiler!

with a proper depth buffer:
Warning: Spoiler!
Last edit: 1 year 3 months ago by Jesped. Reason: Adding more info

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago - 1 year 3 months ago #2 by Jesped
Replied by Jesped on topic Depth loss in Assetto Corsa Competizione
then other tracks, like SPA or Nürburgring here:
Warning: Spoiler!

doesn't have any proper depth buffer, this is what is showed by default (looks like garage):
Warning: Spoiler!


I can select other entries in the DX11 tab that show something "almost" correct, but there is an empty space on the lower part of the screen that makes it all wrong in the end:
Warning: Spoiler!

Res scaling is 100% at 1080p, and it only happens in some tracks.

Any idea how to fix this?
Last edit: 1 year 3 months ago by Jesped.

Please Log in or Create an account to join the conversation.

More
1 year 3 weeks ago #3 by Jesped
Replied by Jesped on topic Depth loss in Assetto Corsa Competizione
The same happens in Man of Medan, another Unreal Engine 4 title. Is there any way to fix this?



Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #4 by Dany Gee
Replied by Dany Gee on topic Depth loss in Assetto Corsa Competizione
I have the same issue.
But look, someone made it working here:

I just don't know how he did it.
Maybe it was different version of both ACC and Reshade?
Anyways, I'm still hunting for the solution - will post it here once found.

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago - 1 month 3 weeks ago #5 by Dany Gee
Replied by Dany Gee on topic Depth loss in Assetto Corsa Competizione
OK, finally made it with reshade + cinematicDOF.fx


How to:
1. Go to DX11 TAB and select entry with most calls


2.Enable DisplayDepth.fx and check if u get proper looking depth maps.
I had to change Reshade_Depth_Input_is_Reversed to 1 and manually scale it to fill the screen (1.067 x 1.895).


3. Now we need to enter those settings into globals section and reload reshade (bottom button).


4.Now depth effects should work fine, mine did:
Last edit: 1 month 3 weeks ago by Dany Gee.

Please Log in or Create an account to join the conversation.