Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade banner comes up yet no response to keys

ReShade banner comes up yet no response to keys 4 months 2 weeks ago #1

Hi! I installed ReShade to use on Supreme Commander Forged Alliance Forever, which is an online matchmaker for the game Supreme Commander Forged Alliance. Therefore, it uses the Forged Alliance .exe, which I have via Steam. Installing ReShade was easy enough, and when I actually started the game up I was greeted with the 'successful installation" banner prompting me to press "Home". However, when I did this, multiple times, nothing happened. I even edited the .ini file so that the keys required are "Shift + F2", thinking that since the Home key toggles a UI bar in SupCom that might be the issue... but nope. Shift + F2 don't work either.

I haven't tried any other games with ReShade yet, but my keyboard is definitely working, The Shift, F2, and Home keys work. What can I do to get the overlay opening so I can do the tutorial and start using Reshade?
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 4 months 2 days ago #2

Bump
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 4 months 23 hours ago #3

Are you sure the keyboard actually sends the F2 code to the computer? Modern keyboards often assign or remap the F keys, hence the "Fn" (function) button. If F2 works, it should let you rename a file in Windows Explorer. Or does something else happen? Sorry if this has been ruled out already, just what came to mind. Also try to close all programs and tools as well, since sometimes overlays can interfere with one another (MSI Afterburner, Steam overlay, OBSProject, etc. etc.).
Xeon E3-1231 v3, MSI GTX 970 @1446/3903 MHz, 16 GB DDR3-1600
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 4 months 14 hours ago #4

F2 works, Shift works, the Home button works. It's not my keyboard. I don't use any overlays, and I don't bring up the Steam overlay when testing the Steam version of the game (where the .exe is).

I know Supreme Commander Forged Alliance uses DX9 since it's an old game, and I selected DX9 when doing the first install. I know the game can work with Reshade, as evidenced here sfx.thelazy.net/games/preset/1836/

and here forums.faforever.com/viewtopic.php?p=106749

But these are from 2014 and 2015, maybe the newer version of Reshade doesn't support the game anymore???
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 4 months 8 hours ago #5

The same with me!
I think I'm driving crazy how often I tried to get it running.
It's launching and then... nothing more
steamuserimages-a.akamaihd.net/ugc/78861...B2782BCB93432608B33/
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 4 months 2 hours ago #6

I fixed it! My problem was that I was playing in fullscreen. Playing in windowed completely fixed the problem, for whatever reason. I honestly just tried it on a whim.
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 3 months 4 weeks ago #7

MajorasAss wrote:
I fixed it! My problem was that I was playing in fullscreen. Playing in windowed completely fixed the problem, for whatever reason. I honestly just tried it on a whim.
Congratulations!. Reshade is working in windowed mode. And the game looks awesome.
Unfortunately the windowed mode creates some disadvantages: 1. Borders above and beyond 2. Mouse scrolling doesn't work
Have already tried boarderlessgaming, but it is not working.
In most other games reshade works in fullscreen mode. Please fix it for SCFA. The old game looks like new.
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 3 months 4 weeks ago #8

Guess what-- you can go into options in game and re enable fullscreen after you apply the Reshade settings you want. The shaders will stay applied, and you get full monitor resolution! You can't open the Reshade menu after that until you go into windowed again, but honestly it's not that big of a deal.
The administrator has disabled public write access.
The following user(s) said Thank You: Kosmo

ReShade banner comes up yet no response to keys 3 months 4 weeks ago #9

@MajorasAss: Thank you! That's great. I would not have found that out.

Everything works, also mouse scrolling. Reshade stays enabled, even if you leave and restart the game in fullscreen mode, as often you want, until you disable or reconfigure Reshade in windowed mode.

But the dev should fix that issue, cannot be a big deal.
Last Edit: 3 months 4 weeks ago by Kosmo.
The administrator has disabled public write access.

ReShade banner comes up yet no response to keys 3 months 3 weeks ago #10

Okay, good to know. Always remember that you can try to force switching fullscreen and windowed mode by pressing Alt+Enter. It can also be a neat shortcut sparing you long journeys through layers of console-friendly option menus.
Xeon E3-1231 v3, MSI GTX 970 @1446/3903 MHz, 16 GB DDR3-1600
The administrator has disabled public write access.