Welcome, Guest.
Username: Password: Remember me

TOPIC: Windows 10 1903 + d3d9.dll = 0xc0000005 (solved)

Windows 10 1903 + d3d9.dll = 0xc0000005 (solved) 3 weeks 2 days ago #1



I would just like to report that some old games I owned are no longer working with ReShade's d3d9.dll file (error will show up as shown on the screenshot instead) - it doesn't matter which compatibility I select or in admin privileges, will just not run on Windows 10 build 1903. Some games which shares the same engine would still work though which is weird.

Also just to add this up, its not isolated to the Reshade v4's d3d9.dll - its also happening to any old games which has its own d3d9.dll file. Like for instance windows 10 fixes of the d3d9.dll files for any old ILLUSION games will have the same error message popping out.

When I was still using Windows 10 build 1809, I didn't encounter this problem at all with Reshade.

UPDATE: Its happening even if MSI Afterburner is completely uninstalled too, and I don't think its linked to my drivers.

I'm playing other couple of DX9-based games where the Reshade's d3d9.dll is working just fine. Here's the list where it is working...
1. PSO2
2. Automobilista
3. rFactor 1
4. GT Legends
5. ePSXe (PSOne Emulator)

UPDATE (SOLUTION): I found out that using dgvoodoo's D3D9.DLL File, I can use the DX11 Reshade to make it work. So all is good and dandy! Search google for dgvoodoo2 for the program.
Last Edit: 3 weeks 2 days ago by konizu.
The administrator has disabled public write access.

Windows 10 1903 + d3d9.dll = 0xc0000005 (solved) 3 weeks 7 hours ago #2

I've not had a game do this so far, so just in case it does, are you saying you just put the dgVoodoo .dll in the game folder and then do a standard install of Reshade there as a DX11 game and that's it? Or is there something in dgVoodoo like a .ini that needs to be configured to run a second library?
The administrator has disabled public write access.