FiveM/GTAV + Reshade + NVIDIA = Crash on Startup

More
3 years 1 month ago #1 by raina FiveM/GTAV + Reshade + NVIDIA = Crash on Startup was created by raina
Hello! I am trying to use Reshade with FiveM but I encounter an issue when trying to run FiveM through NVIDIA with ReShade. If I do not use my NVIDIA graphics processor and instead use the integrated graphics processor, I can see that the ReShade is installed and working. However, FiveM will not open properly this way and needs to use the NVIDIA processor--which crashes immediately upon startup if I have ReShade installed with this error code: d3d11.dll+CE432

This is a more in-depth summary of the crash:

[ 0] Initialized system mapping!
[ 79] Hooked external (mobile) GPU drivers to force enablement.
[ 188] CitizenFX Steam child starting - command line: C:\Users\Raina\AppData\Local\FiveM\FiveM.exe
[ 1938] Initialized system mapping!
[ 2125] CitizenFX Steam child starting - command line: C:\Users\Raina\AppData\Local\FiveM\FiveM.exe
[ 2235] Loaded d3d10.dll!
[ 2235] hello from C:\Users\Raina\AppData\Local\FiveM\FiveM.exe
[ 2329] Got ros:launcher process - pid 13112
[ 2360] Initialized system mapping!
[ 2438] C:\Users\Raina\AppData\Local\FiveM\FiveM.app\citizen\clr2\lib\mono\4.5 CitizenFX.Core.pdb is not a platform image (even though the dir matches).
[ 2532] MumbleAudioInput::InitializeAudioDevice: Initialized audio capture device.
[ 2563] hello from "C:\Users\Raina\AppData\Local\FiveM\FiveM.app\cache\subprocess\FiveM_ROSLauncher" ros:launcher --parent_pid=16404 "C:\Program Files\Rockstar Games\Grand Theft Auto V\GTAVLauncher.exe"
[ 2610] launcher! "C:\Users\Raina\AppData\Local\FiveM\FiveM.app\cache\subprocess\FiveM_ROSLauncher" ros:launcher --parent_pid=16404 "C:\Program Files\Rockstar Games\Grand Theft Auto V\GTAVLauncher.exe"
[ 2625] Initialized system mapping!
[ 2672] Replacing function table list entry 0x140564000 with 0x140564000
[ 3391] Replacing function table list entry 0x142e1c000 with 0x142e1c000
[ 3438] Skipping XAudio2 patches - XAudio 2.7 is present.
[ 3454] [FontRenderer] Initializing DirectWrite.
[ 4079] Initialized system mapping!
[ 4094] Hooked external (mobile) GPU drivers to force enablement.
[ 4219] CitizenFX Steam child starting - command line: "C:\Users\Raina\AppData\Local\FiveM\FiveM.app\cache\subprocess\FiveM_ChromeBrowser" --type=gpu-process --field-trial-handle=3308,7341100115569763023,7549996596599091325,131072 --disable-features=VizDisplayCompositor --no-sandbox --use-angle=d3d11 --disable-direct-composition --locales-dir-path="C:\Users\Raina\AppData\Local\FiveM\FiveM.app\bin/cef/" --log-file="C:\Users\Raina\AppData\Local\FiveM\FiveM.app\cef.log" --resources-dir-path="C:\Users\Raina\AppData\Local\FiveM\FiveM.app\bin/cef/" --lang=en-US --gpu-preferences=KAAAAAAAAACAAwAAAQAAAAAAAAAAAGAAAAAAAAUAAAAIAAAAAAAAACgAAAAEAAAAIAAAAAAAAAAoAAAAAAAAADAAAAAAAAAAOAAAAAAAAAAQAAAAAAAAAAAAAAAFAAAAEAAAAAAAAAAAAAAABgAAABAAAAAAAAAAAQAAAAUAAAAQAAAAAAAAAAEAAAAGAAAA --log-file="C:\Users\Raina\AppData\Local\FiveM\FiveM.app\cef.log" --service-request-channel-token=9075689467957018648 --mojo-platform-channel-handle=3316 /prefetch:2
[ 4266] Hooked external (mobile) GPU drivers to force enablement.
[ 4344] C:\Users\Raina\AppData\Local\FiveM\FiveM.app\citizen\clr2\lib\mono\4.5 MsgPack.dll is not a platform image (even though the dir matches).
[ 4625] Hooked external (mobile) GPU drivers to force enablement.
[ 5766] Process crash captured. Crash dialog content:
[ 5766] d3d11.dll+CE432
[ 5782] An error at d3d11.dll+CE432 caused FiveM to stop working. A crash report is being uploaded to the FiveM developers. If you require immediate support, please visit <A HREF=" forum.fivem.net/ ">FiveM.net and mention the details below.
[ 5797]
[ 5813] Legacy crash hash: quebec-sweet-low

I deleted FiveM and ReShade to a fresh install of both and the issue persisted. I have tried renaming the dxgi.dll file to both d3d11.dll and d3d10.dll. The first allows FiveM to start up without a crash, but ReShade does not load. The second (the one the FiveM forum recommends) causes the crash. I have one mod installed, the Terrov graphics mod--and tried two different versions of it to the same result. I exited all programs that could possibly have an overlay, including Steam and Discord. I'm at a bit of a loss and would appreciate any help possible.

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.