Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade Key does not work in Wizardry 8

Reshade Key does not work in Wizardry 8 3 weeks 2 days ago #1

Hi,
I tried to use Reshade on Wizardry 8 (GOG version), but it fails at the last step :(

The Reshade shaders load and show me the "tutorial" overlay, asking me to press "Home or Pos1". But when I press that key nothing happens. When I change the key in Reshade.ini to another key, the overlay says that I should press that other key, but pressing that key doesn't do anything either. As if the key-presses doesn't reach the Reshade overlay (they keys are recognized as ingame controls though).

I tried various methods to use Reshade:
a) configuring the game with OpenGL, downloading the Reshade OpenGL shaders (note that for getting the game to run this way it needs the /windowed command added in the launch link otherwise it crashes)
b) using dgvoodoo replacing the 3 glide.dlls, configuring the game with glide2x, downloading the Reshade DirectX10+ shaders

The results are the same on both: The overlay appears but the key is not recognized.

I'm using Reshade 4.2.1, but the same results happen with Reshade 4.4. I have to avoid 4.4 however, because of .NET Framework 4.8, which crashes the Reshade App on Windows 7 64bit and even crashes my iGPU (Intel HD4400) Control Center. That's why I'm using 4.2.1 and .NET Framework 4.6.

Any ideas how to fix the key recognition?
Last Edit: 3 weeks 2 days ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 3 weeks 2 days ago #2

Try closing any programs (OBS) or functions (GOG overlay) that might interfere with this as they might have their own layer obstructing the key press.
Also try using all three modes if available: fullscreen, borderless fullscreen and windowed. I'd stick with Pos1 again just to be sure that this time it's not because of a wrong entry.
Xeon E3-1231 v3, MSI GTX 970 @1446/3903 MHz, 16 GB DDR3-1600
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 3 weeks 1 day ago #3

I tried changing fullscreen/windowed as good as the game allowed without crashing, but it didn't change anything.
I also have no other applications running, no Antiviruses, no Instant Messengers, no GOG overlay (using the offline installer version of Wizardry8 ), nothing. It's also a fresh Windows 7 install.

I tried then to use DirectX7 in the game settings and use dgvoodoo2 (where I had to copy 4 dlls into the Wizardry folder). The game started up promising with the dgvoodoo watermark, and the Reshade tutorial overlay already in Sirtech-Games intro, giving it a pink or yellow hue, but when it should change to the game menu it always crashes. This doesn't seem to be a Reshade error though, because it crashes also without it. Some DDRAW.dll error if I interprete it correctly from the Windows events logs, which indicates an issue with that one dgvoodoo2 dll. During the intro however the "Home/Pos1" didn't work either though. So maybe even there would be the problem, that it doesn't recognise the key.
Using DirectX7 in the game settings without the dgvoodoo2 files works flawlessly however (though it doesn't recognise Reshade).

I'm not sure why it makes so much trouble. Maybe it's because of Windows 7. I have seen one post in the Steam forums claiming Wizardry 8 runs fine with Reshade in Windows 10. I'd be fine with that if it's true, because then I'd just try it again when I upgrade the computer and software in the future. But it still seems strange, as there existed an old SweetFX version with worked with the game years ago as seen in this rgpcodex post. I didn't try that on my system though, because that was years ago, and Reshade has probably changed and improved a lot since then.

Maybe it's also the iGPU causing problems. I'd be fine with that, to check the game in the future with a real GPU then. If I only knew, if that's the real issue. Or maybe the game itself is just stubborn.
Last Edit: 3 weeks 1 day ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 3 weeks 1 day ago #4

I have to update that last attempt with using DirectX7 and using dgvoodoo2 with the following information:
When I deleted the whole Flics folder (that's where all the movies are located from the game) the game didn't crash. So I got into the game with the Reshade overlay - but once again the same issue happens: the "Home/Pos1" key isn't recognised at all. Nothing happens when pressing that key. I also switched between windowed and fullscreen mode during the game, but this also didn't make the key recognised.
Last Edit: 3 weeks 1 day ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 3 weeks 1 day ago #5

Ok, I give up.

I have even made the effort to install Windows 10 and try Reshade there (this time the newest Reshade 4.4. version and .NET Framework 4.8 ). At least the .NET Framework didn't produce problems there. The biggest issue remained however: The "Home/Pos1" key was again not recognised.

I'm out of ideas now. Obviously it doesn't matter if Windows 7 or Windows 10.
Personally I would say the iGPU is the reason for it not working.
Another possibility is, that the Steam version of the game is "magically different" than the GOG version of the game - different folder structure, other dlls or something like that? I don't know. But according to this post it works there...
Last Edit: 3 weeks 1 day ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 2 weeks 4 days ago #6

Considering that the HOME key may simply not be recognized, I tried to map this key with the XMouse application to a mouse button. Didn't help either.
Then I tried to use the Windows OnScreenKeyboard and click on the HOME key, but it didn't help either.
Also tried again to manually add the button "A" in the Reshade.ini with the same attempts above, and for OpenGL, DirectX7, nGlide. Didn't help either.
Also tried to uncheck all shaders on install except "Vibrance". Didn't help either. That said the DXGI log does not show any errors when registering the shaders anyways...

I'm really not sure why it doesn't react. Maybe it's really the iGPU. Or the application simply does not work with it. I read something about possible issues when the game uses image-overlays. Considering that large parts of the Wizardry UI are probably image overlays, this could be a reason.
Last Edit: 2 weeks 2 days ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 2 weeks 3 days ago #7

Hello again. I achieved a minor success:

I crawled through the repository of older versions and eventually choose "Reshade 1.1.0 with SweetFX 2.0.7z" www.mediafire.com/folder/8ar1jhh1809cl/R...sitory#9dd4f84o9l99n

I installed it using OpenGL settings, configured Wizardry8 using OpenGL, and also added the /windowed command to the launcher again.

Then I started the game - and this was the first time I saw special effects applied in the game menu and ingame! I also verified it by changing some values in the SweetFX_settings.txt. It only worked with OpenGL however, not with DirectX7 and dgVoodoo.

However I also encountered the same issue as before, which was that I couldn't toggle the effect on and off. The ToggleKey (in this case Scroll_Lock) doesn't react or is not recognized either. The only key recognized was "Print Screen". I noticed however that "Print Screen" makes 2 Screenshots: one with effects and one without. That means that Reshade somehow recognizes this key! I then tried to remap this key to an Effect-ToggleKey, but wasn't successful.
Despite that, the effects work. But only in this combined Reshade-SweetFX version, and only because they are applied right on startup and don't require to be toggled in.

For now this is the only package I know of, that works with Wizardry 8.
Last Edit: 2 weeks 2 days ago by Rsguest.
The administrator has disabled public write access.

Reshade Key does not work in Wizardry 8 2 weeks 2 days ago #8

The "Print Screen" key being recognized gave me a new idea: Why not use this key as a ToggleKey on the more recent Reshade versions?
So I made clean Wizardry 8 install again, installed Reshade 4.2.1, configured it with OpenGL again.

I also added the following lines in Reshade.ini:
[INPUT]
KeyMenu=44,0,0

It loaded up with the default welcome message: "ReShade is now installed successfully. Please press 'Print Screen' to start the tutorial." This is as far as I ever came (with the more recent Reshade versions). Then I pressed the 'Print Screen' - and finally a Reshade Menu overlay appeared, showing tabs like Home, Settings, Statistics, Log, About, and another message with a "Continue" button.

That's it for the good news. The bad news is, that at this point I'm stuck again. I cannot click anything with the mouse. The only thing I can do, is scroll the mousewheel to see the full message. The mousepointer movement is strange as well: I move the mouse - but the mousepointer doesn't move in the overlay - but when I scroll the mousewheel - the mousepointer suddenly "teleports" to the position it should be. So the mouse pointer position only "updates" after scrolling the mousewheel. It only updates its position though, not the mouseclicks. It doesn't register the clicks. When the mousepointer is over one of the Reshade menu buttons, it still highlights them.
Other than that I can't close the overlay anymore. Also not with pressing 'Print Screen' a second time. I must close the whole game using 'Esc' and 'Arrow' keys, or brutally via TaskManager. The 'Ingame Mousepointer' is stuck as well, probably bound to the ReShade overlay, so I can't use it either. 'Esc', 'Tab', 'Ctrl' etc. to navigate in the Reshade Menu do not work btw.

I mean it's a progress, but..... still unusable :unsure:
The issues are btw. exactly the same when using dgVoodoo and DirectX7.
Besides using the 'Print Screen' is also not optimal as a ToggleKey, because it makes a screenshot everytime.

Really the only key being recognised by ReShade (and for this specific game) is 'Print Screen'. But if this key works, wouldn't it be possible to make the other keys work as well?
Last Edit: 2 weeks 2 days ago by Rsguest.
The administrator has disabled public write access.