Quake 4 issues

  • Posts: 292
5 years 2 months ago #1 by matsilagi
So, how some of you ran Quake 4 with ReShade?
I tried running it, but the game never runs with it, yes i placed everything on the right directories.

Please Log in or Create an account to join the conversation.

  • Posts: 267
5 years 2 months ago - 5 years 2 months ago #2 by robgrab
The files I use are:
MasterEffect Reborn, which consists of the following files:
ReShade.fx
mcdirt.png
mclut.png
mcnoise.png


AND

Reshade32.dll, which should be renamed to:
OPENGL32.dll

EDIT: That's what happens when I don't proofread. :P

Please Log in or Create an account to join the conversation.

  • Posts: 3665
5 years 2 months ago #3 by crosire

robgrab wrote: OPENGL.dll

OPENGL32.dll ;)

Please Log in or Create an account to join the conversation.

  • Posts: 292
5 years 2 months ago #4 by matsilagi

robgrab wrote: The files I use are:
MasterEffect Reborn, which consists of the following files:
ReShade.fx
mcdirt.png
mclut.png
mcnoise.png


AND

Reshade32.dll, which should be renamed to:
OPENGL.dll


I did that, however, the game runs (taskmanager shows its EXE) then quits.

Please Log in or Create an account to join the conversation.

  • Posts: 3665
5 years 2 months ago #5 by crosire
Sounds like a typical overlay conflict problem to me. Anything running?

Please Log in or Create an account to join the conversation.

  • Posts: 267
5 years 2 months ago #6 by robgrab
It works perfect for me although I do have Steam overlay disabled. Not sure if that makes a difference.

Please Log in or Create an account to join the conversation.

  • Posts: 292
5 years 2 months ago #7 by matsilagi

robgrab wrote: It works perfect for me although I do have Steam overlay disabled. Not sure if that makes a difference.


Running Nosteam and patched, thats not the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 267
5 years 2 months ago #8 by robgrab
Not sure if it makes any difference but I'm also running Quake 4 with the Quake 4 Evolved 1.0 mod.

Please Log in or Create an account to join the conversation.

  • Posts: 292
5 years 2 months ago #9 by matsilagi

robgrab wrote: Not sure if it makes any difference but I'm also running Quake 4 with the Quake 4 Evolved 1.0 mod.


Same thing, i will just reinstall it.
Also, judging from Doom 3 BFG, the framerate loss will be big for me :v

Please Log in or Create an account to join the conversation.

  • Posts: 144
2 years 3 weeks ago #10 by brazzjazz
Having the same problem - no input detected, I'm unable to interact with ReShade other than activating or deactivating the settings windows through Shift+F2. I'm using the Quake 4 version from the CD-ROM, so no Steam overlay or something like that. DLL is already renamed opengl32.dll. Using ReShade 3.1.2.

Please Log in or Create an account to join the conversation.

  • Posts: 144
1 year 11 months ago #11 by brazzjazz
Update: One way to access the ReShade GUI is to get the game into windowed mode (either through the settings or through Alt+Enter), and to press ~ (the button between Esc and Tab). It has to do with the behavior of the game, also not letting you just alt-tab out of the game, which brought me to the solution in the first place.
See ubuntuforums.org/showthread.php?t=1311090

This is not the exact solution we all want, but for now I'm not aware of any command you could put into autoexec.cfg to change the way Quake 4 binds your mouse input.

Please Log in or Create an account to join the conversation.