Problem with SWTOR

  • Posts: 3
3 months 3 weeks ago #1 by Breat
Hello,

After installing ReShade for SWTOR game, i have a problem :

I don't see my lightsaber, skills effects and loots on monsters

I needed installed ReShade with DirectX 10 if not the game don't start (solution founded on internet).

The problem stay after disabling ReShade, i need rename the "dxgi.dll" in "dxgi.dll.old" for exemple and restart the game to fix it, so ReShade can't be loaded.

Someone can help me ?

Please Log in or Create an account to join the conversation.

  • Posts: 144
3 months 2 weeks ago #2 by brazzjazz
Strange, according to this reshade.me/compatibility SWTOR needs Direct3D 9 (d3d9.dll).

I'm not quite sure whether the problem still persists, even without ReShade?

Please Log in or Create an account to join the conversation.

  • Posts: 3
3 months 2 weeks ago - 3 months 2 weeks ago #3 by Breat
Hello,
If i disable ReShade by the shortkey (SHIFT+F3 for me) the problem stay but if i rename or delete the dxgi.dll and restart the game, it's good no more problem but no more ReShade too :)

If i install ReShade with DX9, then the launcher start but when i click on Play nothing happend and no process of swtor.exe in taks..

Please Log in or Create an account to join the conversation.

  • Posts: 3
2 months 1 week ago #4 by Breat
Hello,
No one have a solution ? I tryed with the lastest version 4.5.3 and I have the same problem.

Please Log in or Create an account to join the conversation.

  • Posts: 5
2 months 1 week ago #5 by Achim93
Maybe try renaming it to d3d10.dll ...

Please Log in or Create an account to join the conversation.