[SOLVED] Problem with SWTOR

More
1 year 7 months ago #1 by Breat
Problem with SWTOR was created by Breat
Hello,

After installing ReShade for SWTOR game, i have a problem :

I don't see my lightsaber, skills effects and loots on monsters

I needed installed ReShade with DirectX 10 if not the game don't start (solution founded on internet).

The problem stay after disabling ReShade, i need rename the "dxgi.dll" in "dxgi.dll.old" for exemple and restart the game to fix it, so ReShade can't be loaded.

Someone can help me ?

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #2 by brazzjazz
Replied by brazzjazz on topic Problem with SWTOR
Strange, according to this reshade.me/compatibility SWTOR needs Direct3D 9 (d3d9.dll).

I'm not quite sure whether the problem still persists, even without ReShade?

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago - 1 year 7 months ago #3 by Breat
Replied by Breat on topic Problem with SWTOR
Hello,
If i disable ReShade by the shortkey (SHIFT+F3 for me) the problem stay but if i rename or delete the dxgi.dll and restart the game, it's good no more problem but no more ReShade too :)

If i install ReShade with DX9, then the launcher start but when i click on Play nothing happend and no process of swtor.exe in taks..
Last edit: 1 year 7 months ago by Breat.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #4 by Breat
Replied by Breat on topic Problem with SWTOR
Hello,
No one have a solution ? I tryed with the lastest version 4.5.3 and I have the same problem.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #5 by Achim93
Replied by Achim93 on topic Problem with SWTOR
Maybe try renaming it to d3d10.dll ...

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6 by Krasius
Replied by Krasius on topic Problem with SWTOR
Use Reshade 4.2.1 and dxgi.dll.
Newer Reshade requires turning Swtor AA setting to Medium.

Please Log in or Create an account to join the conversation.

More
9 months 6 days ago - 9 months 6 days ago #7 by Krasius
Replied by Krasius on topic Problem with SWTOR
I got AA high/very high working with no missing lightsaber/effects on newer Reshade (4.8 atm).
In D3D9 tab, check the box "Disable replacement with INTZ format". Btw I use dxgi.dll in retailclient folder.
Last edit: 9 months 6 days ago by Krasius.

Please Log in or Create an account to join the conversation.