RPCS3 using Vulkan on an Optimus laptop?

  • Posts: 2
2 months 6 days ago - 2 months 6 days ago #1 by PhilJ43
I've trying to use RPCS3 with ReShade. I've got a laptop with Optimus, and if I force the gpu to use the integrated Intel GPU, RPCS3 starts the game and ReShade pops up just fine with Vulkan. If I force the gpu to my 1050ti, I get an error in RPCS3. I'm not sure where/how to find a ReShade log with 4.5.2.
File Attachment:

Normally i've been able to run ReShade with pretty much everything, Optimus hasn't really been a problem as long as I force which gpu to use. I've also seen other people using RPCS3 with Vulkan and ReShade. Just wondering if anyone has any ideas?

Please Log in or Create an account to join the conversation.

  • Posts: 7
1 month 1 week ago #2 by ssjgoku4
i am facing the same problem with rpcs3. i have gtx 970m with optimus and reshade works with everything except rpcs3. even works on xenia xbox 360 emulator.

Please Log in or Create an account to join the conversation.

  • Posts: 2
1 month 1 week ago #3 by PhilJ43
Yeah, I still can't get it going. I've tried unofficial builds that seem to work for other people, and everything I could think of in between. No good.

Please Log in or Create an account to join the conversation.

  • Posts: 7
1 month 4 days ago #4 by ssjgoku4
i have searched and didnt find any workaround for this issue. meanwhile people are play games on rpcs3 with raytracing shader dont know how they made it work for them.

Please Log in or Create an account to join the conversation.