ReShade does nothing; acts as if not installed

  • Posts: 2
1 month 1 week ago #1 by A6MZero
I've been trying to run ReShade with Star Wars: The Old Republic, and have found that despite following the instructions, tutorials and troubleshooting I could find ReShade does absolutely nothing. I don't have any overlays running or anything else modifying the game, and I've triple checked that everything has been installed in the correct locations and with the correct settings. Installation seems to work perfectly, with no errors and all the files appearing in their proper place. No pop-up registering's it's active, no overlay, no graphics changes, not even a crash; simply put, the game acts as if absolutely nothing had been installed or changed. The only indication that anything at all has occurred is the creation of a dxgi.log file, invariably containing the following:

22:56:35:535 [01732] | INFO | Initializing crosire's ReShade version '4.5.3.756' (32-bit) built on '2020-01-12 15:49:01' loaded from "d:\games\star wars-the old republic\swtor\retailclient\dxgi.dll" into "d:\games\star wars-the old republic\swtor\retailclient\swtor.exe" ...
22:56:35:650 [01732] | INFO | Registering hooks for "user32.dll" ...
22:56:35:650 [01732] | INFO | > Libraries loaded.
22:56:35:650 [01732] | INFO | > Found 13 match(es). Installing ...
22:56:35:679 [01732] | INFO | Registering hooks for "ws2_32.dll" ...
22:56:35:679 [01732] | INFO | > Libraries loaded.
22:56:35:679 [01732] | INFO | > Found 8 match(es). Installing ...
22:56:35:708 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d9.dll" ...
22:56:35:708 [01732] | INFO | > Libraries loaded.
22:56:35:708 [01732] | INFO | > Found 9 match(es). Installing ...
22:56:35:737 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10.dll" ...
22:56:35:737 [01732] | INFO | > Delayed.
22:56:35:737 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10_1.dll" ...
22:56:35:737 [01732] | INFO | > Delayed.
22:56:35:737 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d11.dll" ...
22:56:35:737 [01732] | INFO | > Delayed.
22:56:35:738 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d12.dll" ...
22:56:35:738 [01732] | INFO | > Delayed.
22:56:35:738 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\dxgi.dll" ...
22:56:35:738 [01732] | INFO | > Delayed until first call to an exported function.
22:56:35:738 [01732] | INFO | Registering hooks for "C:\WINDOWS\system32\opengl32.dll" ...
22:56:35:738 [01732] | INFO | > Delayed.
22:56:35:738 [01732] | INFO | Initialized.
22:56:35:738 [01732] | INFO | Redirecting CreateDXGIFactory(riid = {7B7166EC-21C7-44AE-B21A-C9AE321AE369}, ppFactory = 0098F760) ...
22:56:35:738 [01732] | INFO | > Passing on to CreateDXGIFactory1:
22:56:35:738 [01732] | INFO | Redirecting CreateDXGIFactory1(riid = {7B7166EC-21C7-44AE-B21A-C9AE321AE369}, ppFactory = 0098F760) ...
22:56:35:740 [01732] | INFO | Installing export hooks for "C:\WINDOWS\system32\dxgi.dll" ...
22:56:35:740 [01732] | INFO | > Found 7 match(es). Installing ...
22:56:35:743 [01732] | INFO | Exiting ...
22:56:35:743 [01732] | INFO | Uninstalling 45 hook(s) ...
22:56:35:773 [01732] | INFO | Finished exiting.


Unfortunately I don't have the technical knowledge to really interpret that, and searching for similar logs online found only a small number with similar logs and no resolution. Any help would be greatly appreciated, as all my own efforts have produced nothing.

Please Log in or Create an account to join the conversation.