Flickering in Mass Effect 2

  • Posts: 4
5 months 1 week ago #1 by whoswho
I'm having an issue with Mass Effect 2. I'm using the d3d9 fix to get depth buffering to work. But during some cut scenes, specifically with holograms present, the effects start flickering. I think it has something to do with how holograms are rendered in game. They seam to be rendered as a separate scene, that isn't visible to the camera. Reshade is trying to apply effects to both at the same time.
Is there any way to fix this? Has anyone had similar issues?

Please Log in or Create an account to join the conversation.

  • Posts: 4
5 months 1 week ago #2 by whoswho
The problem has gotten worse. Now the depth buffer is missing entirely and only flickers on every once in a while. It's like for every second rendered, only one frame receives a depth buffer.

Please Log in or Create an account to join the conversation.

  • Posts: 6
4 months 3 weeks ago #3 by commandocoki
I know this may sound really stupid but try with no wifi connection.
Its the only way I could actually get mine to work. Different game but very very similar issue. The flickering just ugh!
Hope you find answers.

Please Log in or Create an account to join the conversation.

  • Posts: 2
1 month 2 weeks ago - 1 month 2 weeks ago #4 by Mirari
I can confirm I am having the same issue.

No wifi might work for some because, to my understanding, network activity disables depth detection to prevent online cheating etc.

However, depth flicker starts for me in certain in-game scenarios regardless of being connected to wifi or not. In the DXD9 panel I can see the depth buffer is not being deactivated due to network activity.

It is a mystery to me why depth detection randomly bugs out in this game.

Please Log in or Create an account to join the conversation.