ReShade and popup windows? (X-Plane 11)

  • Posts: 4
4 weeks 1 day ago #1 by Crash-n-Burn
I'm trying to install ReShade into X-Plane 11 and I have a multi-monitor setup with the GPS 530 and 430 on their own windows on the second screen under an Air Manager instrument panel. It seems like ReShade wants to "run" on those panels as well? When I originally installed ReShade and started up XP11, I got the "Loading (73 effects remaining).... This might take a while" message and an hour later, it was still there. I then closed XP, started it up again, same thing. I closed the 530 and 430 windows, restarted XP11, and ReShade did not give me the loading message anymore, it just says "Press Home to open the configuration menu." I un-dock the GPS 530, everything's fine. As soon as I make the 530 a separate window, Reshade gives me the "Loading" message again.

Is this normal? Is this something I just have to sit through? The "73 effects remaining" message does not count down no matter how long I wait.

BTW, when ReShade tries to load, my framerates drop from 60fps to 2-3fps.

Please Log in or Create an account to join the conversation.

  • Posts: 4
4 weeks 2 hours ago #2 by Crash-n-Burn
I like to pull out the GPS or Garmin windows and display them on my touchscreen. When I do this, ReShade seems to have a fit and doesn't like it. In this example, I only had 1 preset loaded and XP11 struggled. When I installed all presets, XP just froze. Notice the ReShade message on the main screen and on the two pull out displays.



I moved one display into my main screen and you can see how ReShade has a message (left side) and once I close the GPS window, ReShade just has the standard welcome message (right side) and then disappears. It's not clear in the screenshots but with the GPS window and ReShade's "loading" message, FPS drops to 20-ish, closing the GPS window and ReShade behaving itself and FPS is 30+. My FPS without ReShade and with the two GPS windows is 30+, so it is ReShade not liking the GPS windows that causes the framerate drops.




Anyone else here using ReShade and pulling out their GPS/Garmin windows? Is there a way to get around this issue?

Please Log in or Create an account to join the conversation.

  • Posts: 3671
4 weeks 2 hours ago #3 by crosire
Set this in ReShade.ini to disable loading on startup. You'll need to manually reload in the main window of course.
[GENERAL]
NoReloadOnInit=1
This is normal otherwise, since ReShade applies to every window separately. But if that window is not updated frequently (like a game window should be), things will break.

Please Log in or Create an account to join the conversation.

  • Posts: 4
4 weeks 52 minutes ago #4 by Crash-n-Burn
Thank you, I will try that.

Please Log in or Create an account to join the conversation.

  • Posts: 4
3 weeks 6 days ago - 3 weeks 6 days ago #5 by Crash-n-Burn
That did not seem to work. Here is how my setup looks like with ReShade on:



The welcome message is displayed on the main window instead of the loading message, but the welcome message is also displayed on the two GPS units on the touchscreen. The welcome message does not go away even after 10+ minutes and my FPS is lower than normal. Closing the GPS windows brings my FPS back up and the welcome message goes away by itself after 20 seconds or so.

Here is my .ini file:
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.