ReShade not working with Mound & Blade 2 Bannerlord

  • Posts: 7
3 months 2 weeks ago - 3 months 2 weeks ago #1 by WinglessCut
I've been trying to troubleshoot this on various different forums, from reddit, to Steam and now I come to the OG place where I hope I can get this sorted.

I tried installing the latest ReShade to Mount & Blade 2 Bannerlord. Installed all the shaders and textures that was given in the installation process. However when starting M&B Bannerlord, the ReShade notification at the top doesn't show and so ReShade doesn't start.

Here's the thing, M&B Bannerlord has 4 exe's in the main directory:

- Bannerlord_BE

- Bannerlord

- Bannerlord.Native

- TaleWorlds.MountAndBlade.Launcher

Looking over preset reshades which people have uploaded on nexus mods, some mod creators state that you should apply ReShade to Bannerlord.exe, yet there are also some who say you should apply it to TaleWorlds.MountAndBlade.Launcher.exe . I've tried both and still same problem.

I've looked over some of the other comments on nexus mods and have tried:

- renaming dxgi.dll to d3d11.dll

- setting all 4 Bannerlord exe files to admin in Win64_Shipping_Client folder

Weird thing is, if I launch bannerlord from directory with Bannerlord.exe then this is when ReShade will start ingame. However, then I can't use mods because the mods require launcher to be launched at the start. But if I launch the game the normal way (which runs through TaleWorlds.MountAndBlade.Launcher.exe) then ReShade doesn't start up.

Hoping someone could help me with this issue. I've been on Reddit, Steam, Nexus mods and it's just doing my head in that I see others able to use ReShade yet I some how can't.

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 months 1 week ago #2 by James snow
I have the same issue

Please Log in or Create an account to join the conversation.