Hitman Silent Assassin (2nd Hitman game) - pitch-black character models

More
5 months 3 weeks ago #1 by Redundanz
Hi all,

seemingly related to some global lightsource (or maybe that's still a wrong guess...) I get this behaviour :

streamable.com/iohbtx

I had this issue for a while now but decided to make a forum account only today. I had this in basically all previous ReShade releases that I used but it is also tested with the newest 4.6.1 of course.
Not to forget to add that it happens with disabled and enabled effects.
The issue does not appear when I remove the ReShade opengl32.dll -> hence not loading ReShade at all.

I am not sure if this is something that can be easily fixed by some config file magic which I don't have any experience with, especially when it comes to those special DX/OGL or preprocessor settings...
or if this is something that would have to be changed in the release... in which case I am fully aware that this might not be a priority at all.

THanks!

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago - 5 months 2 weeks ago #2 by crosire
Reproduces with or without ReShade for me, so I don't see how ReShade is the problem.

Switching the game to use DX for rendering fixes it though ("DrawDll RenderD3D.dll" in Hitman2.ini). So you can do that and then use d3d8to9 ( github.com/crosire/d3d8to9/releases ) to get ReShade working (installed as d3d9.dll).
Last edit: 5 months 2 weeks ago by crosire.
The following user(s) said Thank You: Redundanz

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #3 by Redundanz
Thank you so much , yes , the ini change did fix it. After adding d3d8to9 and renaming the opengl32.dll to d3d9.dll it is working with ReShade ! And without dark models!

What's strange though is , that I retried it without any ReShade installation and in OpenGL i 100% do not get the dark models.

But that's not important anymore ... DX8-9 works great! Somehow even looks better color wise, can't put my finger on it... OpenGL looked pale...

Please Log in or Create an account to join the conversation.