Comic.fx only affects the 3D-UI-Avatars in Warcraft 3 Reforged

More
5 months 1 week ago - 5 months 1 week ago #1 by Reshade-Jack
Hi Reshade-Community,

Rehade-Version: 4.6.1
DirectX 10/11/12

I am currently trying to create a custom Reshade for Wc3 Reforged that should improve visibility of terrain and units. One of my favourite Tools for that would be the Comic.fx Shader. Unfortunately it does work only for a very short period of time ingame. The outlines 1 and 2 are disapearing as soon as i select a random unit/structure in this game. Then the selected unit's 3D-Avatar in the UI will load and the outlines will only be drawn around this avatar and the rest of the entire scenerey is ignored. The following Video Shows the Problem in WC3 Reforged. I used extra thick outlines 2, so it will be easy to notice.



It seems to me like Reshade gets confused which 3D-Layer has to be adressed. I saw a similar behaviour with other 3D-Effecs like Ambient occlussion.

Is there any solution for this Problem?

Greetings to you all.
Last edit: 5 months 1 week ago by Reshade-Jack.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #2 by Uncle Crassius
Can you just disable 3d avatars in W3? Total War: Warhammer has a similar issue if animated avatars are activated and disabling them helps.
The following user(s) said Thank You: Reshade-Jack

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #3 by Reshade-Jack
No, it is not possible to turn them off. So that means, that Reshade loses a lot of its shaders to all games, that are using 2 different layers with 3D-Content in it? May be an optional shader/FX Code could swap the prefered layer for Reshade, so you can basically pick one - that would be cool.
Last edit: 5 months 1 week ago by Reshade-Jack.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #4 by Uncle Crassius
Reshade at least offers the option to choose different depth buffers in the DX11 tab in the ui. If you haven't tried that yet, that is.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #5 by Reshade-Jack
That did solve the Problem but created a new one on the other side.

Now the Comic Outlines are rendered..but they shine through UI Elements as well. If an outlined object is hidden behind an ui element, ist outlines will still be visible. Looks Pretty uggly and i have no idea how to get rid of that.

Is there a way to exclude certain parts of the screen from the Reshade effects, so i can mask out the UI? I saw there is a function like UI MAsk top / Bottom...but i really do not understand how to use this tool.

Edit: Just tested UImasktop and UIMask Bottom. It does not seem to detect the WC3 Reforged UI and it is a pure White Mask.
Last edit: 5 months 1 week ago by Reshade-Jack.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #6 by Tojkar

Reshade-Jack wrote: Edit: Just tested UImasktop and UIMask Bottom. It does not seem to detect the WC3 Reforged UI and it is a pure White Mask.


There isn't any kind of detection. You have to make the mask by yourself. Take a screenshot of the game and open it in the image editor of your choice. Gimp or PS highly recommended. Paint the ui elements or any other things you don't want the shader to bleed through black and everything else white. Save that in the texture folder overriding the original uimask.png(can't remember the exact name) and volĂ , you're done.
The following user(s) said Thank You: Reshade-Jack

Please Log in or Create an account to join the conversation.

More
5 months 3 days ago #7 by Reshade-Jack
I followed your advice. It seems to work now and the General UI is protected with a Selfmade UIMask.

Thank you!

Please Log in or Create an account to join the conversation.