Sweetfx stuck loading libraries (Reshade 2.0 HDN)

  • Posts: 5
5 years 2 months ago #1 by JR44
My friend has an issue with sweetfx not loading libraries and reading the log theres a section being spammed over and over but idk why its happening as I can play HyperDimension Neptunia Re;birth1 just fine with Reshade. Help will be greatly appreciated :)
His specs:
speccy.piriform.com/results/CeRSSvJzKJp8AXeuupwbo5k
OpenGL32.log:
www.dropbox.com/s/e714rfqw19ah83y/OPENGL32.log?dl=0

Please Log in or Create an account to join the conversation.

  • Posts: 1
5 years 2 months ago #2 by RipInPisces
Something else to quickly add on, whenever SweetFX is downloaded applied to Hyperdimension Neptunia using ReShade Setup, it will work perfectly. But once the computer is shut off and then on again, it will be stuck loading libraries when you launch the game, at least for me. Lastly, I compared and, essentially, have the same OpenGL log as the one linked.

Please Log in or Create an account to join the conversation.

  • Posts: 3747
5 years 2 months ago #3 by crosire

JR44 wrote: sweetfx not loading libraries

What do you mean here?

Please Log in or Create an account to join the conversation.

  • Posts: 5
5 years 2 months ago #4 by JR44
It'll say the usual reshade by crosire and beneath it says "Loading libraries..." and hangs there forever.

Please Log in or Create an account to join the conversation.

  • Posts: 3747
5 years 2 months ago - 5 years 2 months ago #5 by crosire
There is no such message as "Loading libraries ..." in ReShade?

Please Log in or Create an account to join the conversation.

  • Posts: 9
5 years 2 months ago #6 by NaughtyColt
You might mean loading effects? Check out the other post I made at reshade.me/forum/troubleshooting/682-fix...er-3-hang-on-startup

Apparently changing the name of the DLL fixes some issues so this may fix this case as well?

Please Log in or Create an account to join the conversation.

  • Posts: 5
5 years 2 months ago #7 by JR44
yeah its loading effects not libraries. the game uses opengl wouldnt that break things if my friend renames the dll?

Please Log in or Create an account to join the conversation.

  • Posts: 3747
5 years 2 months ago #8 by crosire
Game for some reason is ping-ponging between two OpenGL render contexts every frame. ReShade cannot work with that, it tries to reinitialize on each context switch for that reason, which expresses itself with the infinite "Loading effects ..." loop. Not much you can do about that unfortunately. If the game has a Direct3D mode, use that one. Alternativly this may be triggered by some graphics setting, so try playing around with those.
The following user(s) said Thank You: JR44

Please Log in or Create an account to join the conversation.

  • Posts: 5
5 years 2 months ago #9 by JR44
He didn't change any graphics settings and there's no D3D mode. Thanks for the help anyways, I hope this scenario helps out killing some bugs.

Please Log in or Create an account to join the conversation.