Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] The Witcher 3 - Fullscreen problem

The Witcher 3 - Fullscreen problem 1 year 6 months ago #1

Hi :)

Just heard about the new 2.0 version of Sweet FX and the presets for TW3 that looks amazing, so I tried CineFX. I installed everything correctly I guess, when I launch the game the SweetFX page pops up but then nothing, it just stays like that, and I can't do anything but force-shut the game.

Then, I tried to launch it in windowed mode, and it works ! So my question is, since I obviously don't want to play in windowed mode, how can I get SweetFX 2.0 to work with TW3 in fullscreen ?

Thanks a lot.
The administrator has disabled public write access.

The Witcher 3 - Fullscreen problem 1 year 6 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2451
  • Thank you received: 1391
Any external overlays, recording software or similar running (like Fraps)? If so, shut them down and try again. Fraps for instance has to be started "after" the game loaded up or it will cause trouble.
Cheers, crosire =)
The administrator has disabled public write access.

The Witcher 3 - Fullscreen problem 1 year 6 months ago #3

As far as I know, there's no such program running. I also tried after shutting down things like Nvidia control panel/Geforce Experience, etc, but no changes at all. :/
The administrator has disabled public write access.

The Witcher 3 - Fullscreen problem 1 year 6 months ago #4

Run in borderless windowed.

Works fine on my machine with the Framework (which is GemFX,Sweet FX, and Master Effects all in one package) in fullscreen.

AMD 8370 cpu, crossfire 290x, and windows 7.
The administrator has disabled public write access.

The Witcher 3 - Fullscreen problem 1 year 6 months ago #5

Thanks for the tip, but I'm already doing it for now, and It's not answering my question.

The thing is that my laptop has a full HD screen, so if I want to play borderless I have to play on 1080p or it will not fit the screen. But 1080p is quite demanding and the game is not really fluid, so I took the habit playing TW3 in 900p.

Here's a screenshot to show you what it does when I'm playing on 1600*900p in borderless windowed and I'm switching to fullscreen. It just stays like that and I can't do anything ...
Last Edit: 1 year 6 months ago by AquaManYeah.
The administrator has disabled public write access.

The Witcher 3 - Fullscreen problem 1 year 6 months ago #6

Nevermind, changing dxgi.dll to d3d11.dll solved the problem.
Thanks for the help, and have a nice day !
The administrator has disabled public write access.
The following user(s) said Thank You: BrandonHortman

The Witcher 3 - Fullscreen problem 1 year 6 months ago #7

  • derrame
  • derrame's Avatar
  • Offline
  • Posts: 12
  • Thank you received: 1
i have the same problem, changed dxgi.dll to d3d11.dll but it doesn't work
The administrator has disabled public write access.